Bug 442901 - system-config-language still needs pirut to work
system-config-language still needs pirut to work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-language (Show other bugs)
rawhide
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks: F9Blocker 442567
  Show dependency treegraph
 
Reported: 2008-04-17 10:29 EDT by leigh scott
Modified: 2009-09-21 18:05 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-29 16:21:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
changing path of yumhelpers.glade file (1.27 KB, patch)
2008-04-28 06:54 EDT, Pravin Satpute
no flags Details | Diff

  None (edit)
Description leigh scott 2008-04-17 10:29:37 EDT
Description of problem: system-config-language still needs pirut to work , this
output was generated by trying to install a language pack .



Version-Release number of selected component (if applicable):

system-config-language-1.2.15-2.fc9.noarch


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

[root@localhost leigh]# system-config-language 
Loaded plugins: refresh-packagekit
Excluding Packages in global exclude list
Finished

(system-config-language.py:17059): libglade-WARNING **: could not find glade
file '/usr/share/pirut/ui/yumhelpers.glade'
Traceback (most recent call last):
  File "/usr/share/system-config-language/language_gui.py", line 173, in okClicked
    self.apply()
  File "/usr/share/system-config-language/language_gui.py", line 235, in apply
    install.install_language (self.mainWindow, grpid)                           
  File "/usr/share/system-config-language/gui_install.py", line 385, in
install_language
    self.checkDeps(mainWindow)
  File "/usr/share/system-config-language/gui_install.py", line 121, in checkDeps
    pbar = GuiProgress(_("Resolving dependencies for updates"), mainwin)
  File "/usr/share/system-config-language/gui_progress.py", line 128, in __init__
    self.xml = gtk.glade.XML(gygladefn, domain="pirut")
RuntimeError: could not create GladeXML object
Comment 1 leigh scott 2008-04-20 23:43:04 EDT
Surely it should be using package-kit instead ? 
Comment 2 Daniel Duggan 2008-04-21 04:30:10 EDT
Same Result here as well

$ system-config-language
Loaded plugins: refresh-packagekit

(system-config-language.py:3166): libglade-WARNING **: could not find glade file
'/usr/share/pirut/ui/yumhelpers.glade'
Traceback (most recent call last):
  File "/usr/share/system-config-language/language_gui.py", line 173, in okClicked
    self.apply()
  File "/usr/share/system-config-language/language_gui.py", line 235, in apply
    install.install_language (self.mainWindow, grpid)                           
  File "/usr/share/system-config-language/gui_install.py", line 385, in
install_language
    self.checkDeps(mainWindow)
  File "/usr/share/system-config-language/gui_install.py", line 121, in checkDeps
    pbar = GuiProgress(_("Resolving dependencies for updates"), mainwin)
  File "/usr/share/system-config-language/gui_progress.py", line 128, in __init__
    self.xml = gtk.glade.XML(gygladefn, domain="pirut")
RuntimeError: could not create GladeXML object
$

$ uname -a
Linux alpha 2.6.25-1.fc9.x86_64 #1 SMP Thu Apr 17 01:11:31 EDT 2008 x86_64
x86_64 x86_64 GNU/Linux

$ rpm -aq | grep system-config-language
system-config-language-1.2.15-2.fc9.noarch








Comment 3 Luis Felipe Marzagao 2008-04-24 23:37:56 EDT
Same here:

[root@localhost ~]# rpm -q system-config-language
system-config-language-1.2.15-2.fc9.noarch


[root@localhost ~]# system-config-language 
Loaded plugins: refresh-packagekit

(system-config-language.py:2482): libglade-WARNING **: could not find glade file
'/usr/share/pirut/ui/yumhelpers.glade'
Traceback (most recent call last):
  File "/usr/share/system-config-language/language_gui.py", line 173, in okClicked
    self.apply()
  File "/usr/share/system-config-language/language_gui.py", line 235, in apply
    install.install_language (self.mainWindow, grpid)                           
  File "/usr/share/system-config-language/gui_install.py", line 385, in
install_language
    self.checkDeps(mainWindow)
  File "/usr/share/system-config-language/gui_install.py", line 121, in checkDeps
    pbar = GuiProgress(_("Resolving dependencies for updates"), mainwin)
  File "/usr/share/system-config-language/gui_progress.py", line 128, in __init__
    self.xml = gtk.glade.XML(gygladefn, domain="pirut")
RuntimeError: could not create GladeXML object

Comment 4 Tim Waugh 2008-04-25 13:09:18 EDT
Seems to me that the only dependency is on a single data file from pirut,
yumhelpers.glade.  Couldn't this file just be added to system-config-language?

There is one translatable string in there, "_Details", and without pirut
installed we would miss the translated string for it.  However, IMHO this is
minor in comparison to the language switching tool just not working as in the
current situation.
Comment 5 Pravin Satpute 2008-04-28 02:35:36 EDT
yeah, it is working fine by just adding yumhelpers.glade file at specified location 

yes we can add this file in system-config-language as it uses this file.

thanks Tim for suggestion
Comment 6 Pravin Satpute 2008-04-28 06:54:05 EDT
Created attachment 303959 [details]
changing path of yumhelpers.glade file

added yumhelpers.glade file to /usr/share/system-config-language/
Comment 7 Pravin Satpute 2008-04-28 07:26:06 EDT
built it for rawhide
system-config-language-1.2.15-3
Comment 8 Tim Waugh 2008-04-28 07:47:10 EDT
Pravin: will you build this for F-9 as well as rawhide?
Comment 9 Pravin Satpute 2008-04-28 08:19:42 EDT
Done!!!
Comment 10 Tim Waugh 2008-04-28 12:57:00 EDT
It would be great to get this blocker bug fixed for Fedora 9; currently dist-f9
has the fix but f9-final does not.  Here is the procedure for getting the
package in at this stage:

http://fedoraproject.org/wiki/ReleaseEngineering/FinalFreezePolicy

(apologies if you have already done this)
Comment 11 Jens Petersen 2008-04-28 21:08:41 EDT
I tested system-config-language-1.2.15-3.fc9 and see a new backtrace here:

$ system-config-language 
Loaded plugins: refresh-packagekit
Package lohit-fonts-kannada-2.2.0-1.fc9.noarch already installed and latest version
1:openoffice.org-langpack-kn_IN-2.4.0-12.6.fc9.i386 from rawhide has depsolving
problems
  --> Missing Dependency: openoffice.org-core = 1:2.4.0-12.6.fc9 is needed by
package 1:openoffice.org-langpack-kn_IN-2.4.0-12.6.fc9.i386 (rawhide)
Traceback (most recent call last):
  File "/usr/share/system-config-language/language_gui.py", line 173, in okClicked
    self.apply()
  File "/usr/share/system-config-language/language_gui.py", line 235, in apply
    install.install_language (self.mainWindow, grpid)                           
  File "/usr/share/system-config-language/gui_install.py", line 385, in
install_language
    self.checkDeps(mainWindow)
  File "/usr/share/system-config-language/gui_install.py", line 154, in checkDeps
    d.set_details(string.join(msgs, "\n"))
NameError: global name 'string' is not defined
Comment 12 Jens Petersen 2008-04-29 01:19:09 EDT
So actually above backtrace is caused by locally installing a newer openoffice.org
than in rawhide, so it is a separate issue.  I will file a separate bug for that.
Comment 13 Jens Petersen 2008-04-29 03:17:38 EDT
I filed bug 444568 for comment 11.
Comment 14 Will Woods 2008-04-29 14:39:35 EDT
system-config-language-1.2.15-3.fc9 should appear in tomorrow's Rawhide.
Comment 15 Bill Nottingham 2008-04-29 16:21:18 EDT
Verified.

Note You need to log in before you can comment on or make changes to this bug.