Bug 442926 - evolution: selected email does not match email on screen
evolution: selected email does not match email on screen
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-17 12:24 EDT by Need Real Name
Modified: 2008-06-17 09:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-17 09:53:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 533122 None None None Never
Launchpad 220014 None None None Never

  None (edit)
Description Need Real Name 2008-04-17 12:24:26 EDT
This one might be a blocker.

I have a list of e-mail messages, but when I open some of them either in the
preview pane or by double-clicking, I get a different e-mail message.

This is a data loss bug since I may delete the wrong e-mail. Marking severity as
High.

evolution-2.22.1-1.fc9.i386
evolution-data-server-2.22.1-1.fc9.i386
Comment 1 Need Real Name 2008-04-17 12:26:33 EDT
Restarting evolution or e-d-s did not solve the problem.

As a workaround, to hide the problem, I can do the following:
1. Create a new folder
2. Drag all messages to the new folder
3. Drag all the messages from the new folder back to the original folder
Comment 2 Milan Crha 2008-04-17 13:17:51 EDT
It seems like problem with a summary of the folder. Are there any messages on
the Evolution's console? (In case you run evolution on console and you are able
to reproduce it.)

Maybe it doesn't report problems too loudly. Can you look at Help->Debug Logs
and show all messages, whether you will see there something? I've such a feeling
that it is not stored between sessions, maybe something useful in time of the
issue can be found in ~/.evolution/cache/tmp/mail.log.XXXXXX where XXXXXX is
some unique generated code for each session.
Comment 3 Need Real Name 2008-04-17 13:31:38 EDT
I get one message about a corrupt mbox and a missing From: header.
The messages were kind of off-by-one wrong, so I guess evolution's handling of
missing From: headers needs work..
Comment 4 Milan Crha 2008-04-18 03:50:37 EDT
I recalled it yesterday, at home. It's because of enabled large file support,
your 32bit machine is not ready for such thing yet, we should disable this
feature until it will be really fixed. I'm sorry for inconvenience, that's my fault.
Comment 5 Need Real Name 2008-04-22 02:12:18 EDT
I still have the problem.

evolution-2.22.1-1.fc9.i386
Comment 6 Milan Crha 2008-04-22 08:30:23 EDT
It showed up that the large file support, I was thinking of, is not included in
this evolution release, furthermore, this part is exactly same as in 2.12.x version.

For your case, I would like to suggest to close evolution and remove your
summaries, so it will be recreated on next start (it will start significantly
slower, because downloading necessary info from the server about your messages
in each folder. It has some disadvantages too, because some message flags are
stored only in the summary file, and not on the server (or for local accounts
like POP it's stored only locally (the flags of mails). But anyway, it seems
you've broken your summary files already, so probably no other way to fix it.

First of all run "evolution --force-shutdown", so everything evolution related
will be closed.

Then, if you go to ~/.evolution/mail, there are subdirectories for account
types, like "local", "imap" and so on. In each folder you can see some
.ev-summary files, which you can move somewhere else and let evolution rebuild
it on next start. I would recommend to create a backup of whole ~/.evolution
before any tests, so you will be sure you can go back to previous state in case
something goes wrong. Even more, I would like to suggest to remove also .index
and .cmeta files, so those will be regenerated as well.

I'm not aware of any command or UI option to regenerate indexes/summary files,
unfortunately. One more time, do backup of the folder before playing with files.
Comment 7 Mathias Kende 2008-04-29 16:04:03 EDT
I have the same bug, but the workaround does work because if I move the messages
in a new folder and then back, the message that I get back are those that were
displayed before (in the preview pane) not, those that were in the message list.

But the correct emails are those that are in the list, the shown emails are
duplicate of mails found elsewhere in my mailbox.

So after applying the workaround, all the incorrectly displayed emails are lost.

Also, do you use the "message filter" (not sure of the name) and more precisely,
do you have a rule which include the action "stop the processing" (not sure
either for the title). I believe that this may be related (but that is just an
hypothesis).
Comment 8 Milan Crha 2008-06-17 09:53:36 EDT
Thanks andre for the upstream bug reference. The Gnome bug shows that the
upstream developer has some idea about the issue and will produce a patch,
hopefully soon. Closing this as an upstream, we will push the patch to fedora
as soon as there will be released an upstream version with it.

Note You need to log in before you can comment on or make changes to this bug.