Bug 442933 - Luci inserts "hostname" instead of "ipaddr" for rsa II fencing device
Summary: Luci inserts "hostname" instead of "ipaddr" for rsa II fencing device
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: conga (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
urgent
urgent
Target Milestone: ---
Assignee: Ryan McCabe
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-17 17:02 UTC by Scott Croft
Modified: 2009-04-16 19:48 UTC (History)
5 users (show)

Fixed In Version: RHBA-2008-0798
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 19:14:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0798 normal SHIPPED_LIVE conga bug fix and enhancement update 2008-07-25 19:14:11 UTC

Description Scott Croft 2008-04-17 17:02:58 UTC
Description of problem: When adding a rsa II fencing device via luci for a
cluster it has a field for entering the hostname vice the IP address.


Version-Release number of selected component (if applicable):
luci-0.10.0-6.el5.x86_64 ?


How reproducible: Every time it is used.


Steps to Reproduce:
1. Add a fence device
2. Choose the IBM RSA II
3. Field name is hostname and that is what is added to cluster.conf
  
Actual results: hostname is listed instead of ipaddr and when trying to fence a
node, the results are "failed" due to not being able to reference the ipaddr.


Expected results: The fence device uses ipaddr and not hostname.


Additional info: jparsons has produced a fix which hasn't been implemented at
the client site yet.

Comment 4 Brian Brock 2008-05-23 19:10:53 UTC
the field in the GUI is labeled "Hostname".

But the option in cluster.conf is correctly named "ipaddr".

Is a fqdn hostname truly useful, or does the fencing device require a
dotted-quad IP addres?

Comment 5 Bret Silberman 2008-05-23 19:24:40 UTC
Brian, 

  I thought this issue had been resolved a month ago?

The Luci GUI is labeled hostname, and can take either a hostname or an IP
address.  The problem is in the cluster.conf.  The Luci GUI will write out the
value of this field (either hostname or ip addr) as hostname=a.b.c.d (incorrect)
instead of ipaddr=a.b.c.d (correct).  The daemon that runs on the clustered
machine will call the fencing agent with no parameters, ignoring the hostname=
fields.

Comment 7 Brian Brock 2008-05-23 19:51:46 UTC
fix looks good per comment 5

changing bug state to verified.

Comment 9 errata-xmlrpc 2008-07-25 19:14:30 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0798.html



Note You need to log in before you can comment on or make changes to this bug.