Bug 442938 - Gettext domain not set in polkit-gnome-authorization, messages in English even when translations are provided
Gettext domain not set in polkit-gnome-authorization, messages in English eve...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PolicyKit-gnome (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-17 14:09 EDT by Ville-Pekka Vainio
Modified: 2013-03-05 22:55 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.8-3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 18:05:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville-Pekka Vainio 2008-04-17 14:09:35 EDT
Description of problem:
polkit-gnome-authorization is in English even though I'm using LANG=fi_FI.UTF8
and Finnish translations exist. This is most likely because the gettext domain
is not set. Please see the Ubuntu bug report and the patch they have:

https://bugs.launchpad.net/ubuntu/+source/policykit-gnome/+bug/199255
http://launchpadlibrarian.net/13160136/debdiff_policykit-gnome_0.7-2ubuntu1.txt

Version-Release number of selected component (if applicable):
PolicyKit-gnome-0.8-1.fc9

How reproducible:
Always

Steps to Reproduce:
1. Start polkit-gnome-authorization on a Gnome desktop using some non-English
locale which has translations provided
  
Actual results:
The application is in English.

Expected results:
The application is in the language that the user has chosen, if the correct
translations have been provided.

Additional info:
You might want to check this gettext stuff in other PolicyKit related source
files which use translations. I don't know how to e.g. "reproduce" a screen
asking for authorization to manage packages with PackageKit, but that should
show the messages in the language the user has chosen as well.
Comment 1 Ville-Pekka Vainio 2008-04-17 14:28:10 EDT
I could "reproduce" the screen asking for authorization anyway, at least with
PackageKit that was in Finnish except the header "System policy prevents
removing package". So I believe the main problem here is just
polkit-gnome-authorization.
Comment 2 David Zeuthen 2008-04-17 17:24:06 EDT
Does this work if you do this

 pkill polkit-gnome-manager
 LANG=fi_FI.UTF8 /usr/libexec/polkit-gnome-manager --no-exit

and then from another shell

 polkit-auth --obtain org.freedesktop.policykit.modify-defaults

Comment 3 David Zeuthen 2008-04-17 17:30:31 EDT
FWIW, this works for me

http://people.freedesktop.org/~david/Screenshot-Tunnistaudu.png
Comment 4 David Zeuthen 2008-04-17 17:31:12 EDT
And the reason the main message is in english is that the PolicyKit package
lacks authorizations...
Comment 5 David Zeuthen 2008-04-17 17:36:12 EDT
And just to prove that part of the i18n stuff works too

http://people.freedesktop.org/~david/Screenshot-Tunnistaudu-1.png

This should say something about changing timezones (I don't speak Finnish
sorry!), right?
Comment 6 David Zeuthen 2008-04-17 17:40:28 EDT
So, anyway, I think you the reason you saw the English messages were that you
were logged into an English locale and didn't realize that that the
authentication happens in a separate process spawned from the session bus. So if
logging in into an Finnish locale this should just work. Otherwise please let us
know. Thanks.
Comment 7 Ville-Pekka Vainio 2008-04-17 17:43:05 EDT
I'm sorry, I probably wasn't clear enough. Yes, that window is in Finnish and me
mentioning it without testing as an additional info thing was probably unneeded.

But the Authorization application polkit-gnome-authorization is completely in
English and that's why I made this bug report in the first place. Please take a
look at the Ubuntu bug report and patch as well. Here's a screenshot, this is
from a desktop where those things that you demonstrated do work as well:
http://vpv.fedorapeople.org/misc/Kuvakaappaus-Authorizations.png
Comment 8 David Zeuthen 2008-04-17 18:05:47 EDT
I see. Actually your report was crystal clear, I was just reading it wrong. My
bad. On the upside it made me verify that i18n is working in the auth dialogs.
Oh well. So I've committed the patch upstream and it will land in 0.8-3.fc9. If
you can verify these packages works for you

 http://koji.fedoraproject.org/koji/taskinfo?taskID=571522

it would be nice. Thanks!
Comment 9 Ville-Pekka Vainio 2008-04-17 18:25:51 EDT
The new version does work for me. Thanks!

Note You need to log in before you can comment on or make changes to this bug.