This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 442953 - new version available
new version available
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: a2ps (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On: 443177
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-04-17 16:21 EDT by Patrice Dumas
Modified: 2008-08-25 01:15 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.14-5.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-11 00:38:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2008-04-17 16:21:53 EDT
Description of problem:

http://ftp.gnu.org/gnu/a2ps/a2ps-4.14.tar.gz

is available. Hopefully some patches can be dropped.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Patrice Dumas 2008-04-22 04:39:31 EDT
I'll be looking at it over the week-end.
Comment 2 Tim Waugh 2008-04-22 04:46:35 EDT
Great!  Sorry, haven't got round to it myself yet.
Comment 3 Patrice Dumas 2008-04-22 04:50:01 EDT
Also you didn't grant nor denied my fedora package database asks.
I guess You missed it.

Also I am submitting html2ps, I think it would be better to use it 
as I said in the review.
Comment 4 Patrice Dumas 2008-04-27 17:16:31 EDT
I have something ready. 

I haven't rebased the flex patch and I removed the flex commands, since 
it doesn't seems to be very useful and is a departure from upstream
which is not really needed in my opinion.

I also haven't rerbased the netscape patch since it doesn't work with 
firefox nor seamonkey. So I make this depend on the html2ps review.

Does this seem right?
Comment 5 Patrice Dumas 2008-05-01 10:08:29 EDT
Ok, I have committed in cvs. 

I have put a2ps-4.13-eucjp.patch in cvs since the big chunk (the 
translation) seems to be included now.

I haven't built since it is waiting on html2ps. This leaves you
the opportunity to check what I did.

- update to 4.14
- don't obsolete the provided version of a2ps-i18n
- use html2ps for the html delegation

A side note is that upstream fix for a2ps-shell.patch is very different
(but looks good too).

So far I have only uncommented the patches, I'll clean after some
time in rawhide without issues (including cvs rm).
The following patches are not needed anymore:
a2ps-generate-tarball.sh
a2ps-4.13-flex.patch
a2ps-4.13-varargs.patch
a2ps-tmpdir.patch
a2ps-4.13-bison.patch
a2ps-4.13-malloc.patch
a2ps-shell.patch
a2ps-includes.patch
a2ps-underquoted.patch
a2ps-netscape.patch
a2ps-psset.patch
Comment 6 Patrice Dumas 2008-05-12 11:00:57 EDT
It is built in devel. Should I build it for other branches too?
Comment 7 Bug Zapper 2008-05-14 05:36:01 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Tim Waugh 2008-05-14 11:41:55 EDT
Let's see how it gets on in devel.  Perhaps we can do updates for released
versions if there are no problems.

Thanks for your work on this, and sorry for the slow response. I have --><--
this much time to work on a2ps at the moment.. :-/
Comment 9 Fedora Update System 2008-06-03 03:37:13 EDT
a2ps-4.14-5.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update a2ps'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4782
Comment 10 Fedora Update System 2008-06-11 00:38:11 EDT
a2ps-4.14-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.