Bug 442957 - tty mode (Ctrl-Alt-F1) mode broken
tty mode (Ctrl-Alt-F1) mode broken
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-ati (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Dave Airlie
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-17 16:59 EDT by wdc
Modified: 2009-01-20 16:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:39:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server log output (302.70 KB, text/plain)
2008-04-17 16:59 EDT, wdc
no flags Details

  None (edit)
Description wdc 2008-04-17 16:59:14 EDT
Description of problem:

With the radeon_tp driver, X works fine (at least in 2D modes).
However when you shut down, or go to a TTY style terminal with
Ctrl-Alt-F1 you get a garbled display.  It looks like there's a blank
row between each row of dots that should be displayed.

I think this bug was also seen in Fedora 9 Rawhide for a time, and then was
repaired there.  The relevant Fedora 9 Rawhide patch needs to be back ported to
the radeon_tp driver.

Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1.Hit Ctrl-Alt-F1

  
Actual results:


Expected results:


Additional info:
Comment 1 wdc 2008-04-17 16:59:14 EDT
Created attachment 302809 [details]
X server log output
Comment 2 wdc 2008-05-15 14:12:07 EDT
It has been nearly a month since submitting this bug, and there has been no activity since being assigned 
back on 18 April.

It would be VERY BAD if the exciting radeon_tp driver went live in RHEL 5.2 with so OBVIOUS a 
REGRESSION as "TTY mode does not work at all".  Could SOMEONE please check into this?
Comment 5 Dave Airlie 2008-05-15 21:03:20 EDT
I've requested this for 5.3

VT switching does work fine on most cards with this driver, however there exists
combinations of graphics card and monitor that we couldn't test in time for 5.2,
and these will be dealt with for 5.3.
Comment 6 Cameron Meadors 2008-07-10 14:21:15 EDT
Could you list the combinations of graphics cards and monitor that would exhibit
this bug?
Comment 7 wdc 2008-07-10 15:08:05 EDT
Thank you for looking at this bug.
I am disappointed, though, that you are asking for information that I have already supplied in great detail 
with my attachment of the X0.log output.

If I may presume to read the log file to you, I believe the information you need to move forward is:
Graphics Card:  Chipset: "ATI Radeon X1300/X1550" (ChipID = 0x7183)
Monitor: Monitor name: DELL 2007WFP Manufacturer: DEL  Model: a019  Serial#: 876687948


Comment 15 Dave Airlie 2008-09-12 00:03:37 EDT
MODIFIED

xorg-x11-drv-ati-6.6.3-3.15.el5 is built.
Comment 18 wdc 2008-11-11 16:58:50 EST
I have just tested xorg-x11-drv-ati-6.6.3-3.19.el5 as incorporated in RHEL 5.3 beta.

It FULLY RESOLVES this issue.

This is a really good epoch of the R500 driver.
2d graphics and TTY mode look very good on both the X1300/X1500 system I originally reported on with this bug, and on an Radeon HD 2400 XT system.
The HD 2400 XT is what we've standardized on this year school-wide so this is
a VERY nice level of functionality to have.

I'll note in passing that glxgears still complains that there are no fbconfigs
on the X1300/X1500 system.  3d ain't there for that chipset.

Happily, there is no such error report on the HD 2400 XT, and it runs glxgears
with a peppy frame rate of ~1500.

Do you want to close this bug now, or wait until RHEL 5.3 ships and I test the actual release?  Whichever way you want to manage this bug is fine with me.
Comment 19 Cameron Meadors 2008-12-01 16:28:04 EST
I have also verified this fix on an Mobility Radeon HD 3650.  Marking as VERIFIED.
Comment 21 errata-xmlrpc 2009-01-20 16:39:21 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0166.html

Note You need to log in before you can comment on or make changes to this bug.