Bug 442959 - Please enable CONFIG_RT_GROUP_SCHED
Please enable CONFIG_RT_GROUP_SCHED
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-17 17:08 EDT by Lennart Poettering
Modified: 2008-04-26 23:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-26 23:41:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2008-04-17 17:08:28 EDT
Please enable CONFIG_RT_GROUP_SCHED!

I'd really like to see this option enabled because it would allow it for the
first time in Linux history to run normal user applications with rt scheduling
in a secure way, i.e. without allowing them to lockup the machine. PulseAudio
would greatly benefit if we could enable RT scheduling for it by default.

I wonder however, if http://bugzilla.kernel.org/show_bug.cgi?id=10361 might
become a problem.
Comment 1 Peter Robinson 2008-04-19 15:52:59 EDT
Looks like its in the latest kernel in koji 
http://koji.fedoraproject.org/koji/buildinfo?buildID=46622

Note You need to log in before you can comment on or make changes to this bug.