Bug 442992 - Required font metric files are for sazanami, not kochi
Required font metric files are for sazanami, not kochi
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
high Severity high
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-17 23:07 EDT by Satoru SATOH
Modified: 2010-11-23 23:17 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.34
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-18 23:02:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Satoru SATOH 2008-04-17 23:07:33 EDT
Description of problem:
publican contains font metric files for some Japanese fonts
(kochi-{gothic,mincho}-subst).

However, we (Japanese) don't use those fonts any more. Kochi-subst fonts are now
replaced with Sazanami fonts. As far as I confirmed, both RHEL5+ and Fedora
ships sazanami fonts instead of kochi-subst fonts.


So, required font metric files are for Sazanami, not Kochi-subst.

Could you please regenerate and include font metric files for
sazanami-{gothic,mincho}.ttf, with Fop's TTFReader?

If you cannot please let me know and I will post these metrics files here.


Version-Release number of selected component (if applicable):
publican-0.33-0.fc9.noarch


How reproducible: always


Steps to Reproduce:
1.
2.
3.
  
Actual results:
/usr/share/publican/fop/font-metrics*/kochi-{gothic,mincho}-subst.xml


Expected results:

/usr/share/publican/fop/font-metrics*/sazanami-{gothic,mincho}-subst.xml



Additional info:

It might be better to post as another bug reports for the following issues but
note here just for the record.

 * This version of publican does not look supporting current fop (0.95-0.2) in
rawhide.
   I guess that it perhaps might be neat if there is a version-independent fop.xconf
   for fallback.

   fop-0.20.x is old and has many issues. you may drop the support for it, I guess.


 * Japanese truetype fonts should be embedded to keep portability.
Comment 1 Satoru SATOH 2008-05-08 05:18:19 EDT
I maybe understand the reason for current fop configuration.

RHEL5 have a package named fonts-japanese _looks_ having "kochi-subst*.ttf".
But, you can see these are symlinks to sazanami-*.ttf actually just by looking 
at its RPM SPEC.


(The snippet below is from fonts-japanese.spec in
fonts-japanese-0.20061016-4.el5.src.rpm)

-----------------------------------:X-----------------------------------
%post
{
    ...
    # make symlinks for java referring to old path and fonts
    ln -sf ../../japanese/TrueType/sazanami-gothic.ttf
%{_datadir}/fonts/ja/TrueType/kochi-gothic-subst.ttf || :
    ln -sf ../../japanese/TrueType/sazanami-mincho.ttf
%{_datadir}/fonts/ja/TrueType/kochi-mincho-subst.ttf || :
    ...
}
-----------------------------------:X-----------------------------------

It looks just a quick hack to keep backward compatibility as a temporal solution.
Add to this, current JDK (OpenJDK-1.6.0) is correctly configured to refer to 
sazanami fonts instead of kochi-subst fonts. So symlinks are not needed any more.

It's summarized as follows.

 - rhel5 needs configuration for sazanami fonts even if there are symlinks.
 - fedora needs configuration for sazanami; symlinks to kochi-subst are gone.


P.S. Unfortunately the paths for these fonts are different between rhel5 and fedora.
So the fop configuration file might needed to be generated in accordance with
target during build process.
Comment 2 Bug Zapper 2008-05-14 05:36:46 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Jeff Fearn 2008-05-18 23:02:27 EDT
Switched to sazanami fonts.

Note You need to log in before you can comment on or make changes to this bug.