Bug 44300 - CDROM Install - DriveReady SeekComplete Error
CDROM Install - DriveReady SeekComplete Error
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-12 10:31 EDT by Troy
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-15 11:32:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Troy 2001-06-12 10:31:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.1b1; Mac_PowerPC)

Description of problem:
I have two different machines that I'm trying to install RH 7.1 on. Every 
time I run the installer, everything seems to work until you see 
"Reading package information" in the GUI installer. At this point, the 
installer will not proceed, and the GUI interface locks up.

Going to VC4, I see these errors repeating:

<4>hdb: cdrom_decode_status: status=0x51 { DriveReady 
SeekComplete Error }
<4>hdb: cdrom_decode_status: error=0x30

These messages will repeat several times, then I see:

<4>hdb: ATAPI reset complete
<4>end_request: I/O error, dev 03:40 (hdb), sector 1001696

The sector numbers at the end of the last line increment by multiples 
of 4 each time.

One of these machines ran RH 6.2 for over two years straight without 
issue. I've installed RH 6.2 on both machines without problems, and 
tried the "Upgrade" option on my 7.1 box set CD. I get the same exact 
errors each time.

I've also downloaded ISO images and burned CDs from them. Same 
errors.


How reproducible:
Always

Steps to Reproduce:
1. Insert RH 7.1 CD 1 into CD drive and boot from it
2. Select any kind of install or upgrade method
3. Watch installer freeze, view error messages on VC4
	

Actual Results:  Installation fails. Nothing appears to be written to 
disk. See errors listed above.

Expected Results:  Bootable install.

Additional info:

Here's hardware info on one of the machines:

HP Pavilion 4540, stock CD drive, 2  8GB Seagate hard disks in raid 
configuration (mirrored swap, / & /boot), 128M ram.

The other machine is custom-built, but it is the same machine that 
ran 6.2 without issue for two years. It is currently running 6.2 again, 
but I still cannot upgrade it to 7.1. Clean install still fails as well.



Can I provide any other helpful information?
Comment 1 Brent Fox 2001-06-12 12:29:43 EDT
The kernel is having trouble reading the cdrom for some reason.  This can be a
number of things...bad cd, bad drive, or kernel problem.  Since you've tried
both the retail and downloaded cd, I'm going to rule out a bum disc.  
We have had problems with the kernel trying to use DMA transfers on devices that
can't support it.  Can you try booting with 'linux ide=nodma' and see if that works?
Comment 2 Troy 2001-06-12 12:46:31 EDT
Ok, I tried that, but it didn't seem to help, unfortunately.

I've also investigated installing rpm 4 from source, but that's not going so 
well. Anything else you can recommend?
Comment 3 Brent Fox 2001-06-14 15:35:04 EDT
I don't know exactly what the problem is.  When you downloaded the ISO images,
did you verify that the md5sums were correct before you burned them?
Comment 4 Troy 2001-06-14 15:50:00 EDT
Yes, I did verify the checksums. Disk verification was good, too.

I've run out of steam on this issue. I've setup both of the machines  with 
version 6.2 again, so I'm giving up on 7 for the time being. Perhaps I'll 
check out the next release. But I just don't have any more time to track this 
issue down.

Thank you for your help. I hope the issue can be resolved before the next 
release.

Best Wishes,
Troy

Note You need to log in before you can comment on or make changes to this bug.