This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 443029 - Indic languages {kn,hi,pa}_IN.utf-8 messes display, app is hardly usable
Indic languages {kn,hi,pa}_IN.utf-8 messes display, app is hardly usable
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: slang (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Lichvar
BaseOS QE
https://bugzilla.redhat.com/show_bug....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-18 05:17 EDT by Michal Nowak
Modified: 2013-03-07 21:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-13 12:35:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Result of running newt based app in Indic locale (51.89 KB, image/png)
2008-04-18 05:17 EDT, Michal Nowak
no flags Details

  None (edit)
Description Michal Nowak 2008-04-18 05:17:34 EDT
Description of problem:

Running rhn_register --nox this way LANG=kn_IN.utf-8 rhn_register --nox the
display is totally messed up.

See attached screenshot.

According to $(URL), the problem might be the newt package, snack module.

Version-Release number of selected component (if applicable):
newt-0.52.2-10.el5.i386

How reproducible:
always

Expected results:
clear display like in en_US.utf-8 etc

Additional info:

Hitting Ctrl+L helps a bit, resizing of the newt based app in Konsole (or any
generic term emulator)  window seems to be completely broken -- try to shrink
and then enlarge the window.

https://bugzilla.redhat.com/attachment.cgi?id=302340
Comment 1 Michal Nowak 2008-04-18 05:17:34 EDT
Created attachment 302857 [details]
Result of running newt based app in Indic locale
Comment 2 Michal Nowak 2008-04-18 05:20:19 EDT
It'd be very helpful to hear your opinion in bug 228240.
Comment 3 Miroslav Lichvar 2008-04-18 09:07:26 EDT
This looks like a slang bug.

Please note that probably no terminal emulator packaged in RHEL5 is able to
display Indic scripts properly. Even with this bug fixed there will be some
corruption left.
Comment 4 Miroslav Lichvar 2010-04-13 12:35:26 EDT
We could update the UTF8 tables in slang that are used to determine width of characters to match the tables in glibc, but that wouldn't solve the problem.

It seems that Indic scripts are very hard (if not impossible) to display correctly in full screen terminal applications. Both slang and terminal emulator would have to have a special Indic support and would have to agree on how many columns a word takes.

I'm closing this as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.