Bug 443036 - Nautilus moving file progress dialog showing ugly filename
Nautilus moving file progress dialog showing ugly filename
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-18 07:03 EDT by Javier Alejandro Castro
Modified: 2015-03-03 17:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 12:35:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Dialog with ugly filenames (10.41 KB, image/png)
2008-04-18 07:03 EDT, Javier Alejandro Castro
no flags Details

  None (edit)
Description Javier Alejandro Castro 2008-04-18 07:03:03 EDT
Description of problem:

I moved an ISO image from an ext3 filesystem to a ntfs filesystem. Dialog showed
with ugly chars of the moving filename, as shown on attachment.
Then i did a copy operation, from ext3 to ext3. Same result. 

Version-Release number of selected component (if applicable):

nautilus-2.22.2-3.fc9.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Select a big file to copy/move that is big enough to make nautilus show a
progress dialog.
2. Select copy/move operation.
3. Paste the file on any other folder
  
Actual results:

Provided screenshot. Ugly filename.

Expected results:

Display file name just fine.

Additional info:
Comment 1 Javier Alejandro Castro 2008-04-18 07:03:03 EDT
Created attachment 302875 [details]
Dialog with ugly filenames
Comment 2 Matthias Clasen 2008-04-18 09:36:01 EDT
What is that acual name of the copied file, and what encoding is your locale using ?
Comment 3 Javier Alejandro Castro 2008-04-21 12:39:59 EDT
 The actual name apparently does not matter cause i copied/moved
various files, not just one. I got my locale setting by doing

 set | grep LANG

 it says

 LANG=es_ES.UTF-8


 Now i tried again, and i think it happens with NTFS filesystem, not
with copying/moving inside ext3 fs. May be the problem comes from
something related to the NTFS backend ? GVFS ? GIO ?


 I Hope it helps!
Comment 4 Matthias Clasen 2008-04-21 14:24:55 EDT
Does ls display correct filenames for these files before/after the move ?
Does nautilus itself display the correct names ?
Comment 5 Javier Alejandro Castro 2008-04-21 14:45:29 EDT
Yes.
Yes.

All is fine on the filesystems. The copy/move operation is right.
It think it is just a UI problem. I read somewhere (bugzilla i think) about
pango fonts problems on some rare cases... may be this is some of those cases ?
Comment 6 Bug Zapper 2008-05-14 05:37:18 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2009-06-09 20:14:45 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2009-07-14 12:35:02 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.