Bug 443050 - Fast User Switching not working at all
Fast User Switching not working at all
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-04-18 08:48 EDT by Jakub Jelinek
Modified: 2015-01-14 18:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-02 14:53:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jakub Jelinek 2008-04-18 08:48:06 EDT
Description of problem:

Fast User Switching doesn't seem to work in today's rawhide (fresh install).
Just one normal user created, if I log in, click on the User Switch Applet,
choose Other and on the GDM login screen choose back the only normal user
(which has "Already logged in" text next to it), enter password resp. swipe
finger, then the screen just flickers and after 2s or so I'm offered the GDM
login screen again, this time without the "Already logged in" text next to my
login name.  I can reproduce this reliably, every time.


Version-Release number of selected component (if applicable):

gdm-2.21.10-0.2008.04.11.3.fc9.i386
Comment 1 Jakub Jelinek 2008-04-18 10:22:37 EDT
I'd note that even the home directory was created freshly, so this isn't related
to garbage from older distros in $HOME/.* directories or files.
Comment 2 Martin Ebourne 2008-04-26 19:13:35 EDT
Fast user switching isn't working here either. A fresh preview release install
updated to rawhide.

Two users already logged in
User 2 locks screen
User 1 clicks 'switch user' on screensaver
User 1 enters password in GDM to access current session
Screen flickers and then returns to GDM screen again
User 1's session has been unlocked, but GDM has switched to the wrong virtual
terminal. If you use Ctrl-Alt-Fn you find the active session ready to use.

This happens most if not every time and is a very visible failure of previously
working functionality.

Given the closeness of the F9 release I'm surprised this regression isn't
getting some attention.
Comment 3 Will Woods 2008-04-29 01:19:53 EDT
Seems to be fixed in gdm-2.21.10-0.2008.04.28.1.fc9. You can get it from koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=47545
or just wait a day or two for it to land in rawhide. 
Comment 4 Jakub Jelinek 2008-04-29 04:04:25 EDT
I see just very limited improvement, from the 8 attempts to fast switch user 6
attempts were unsuccessful and 2 were successes, with 2.21.10-0.2008.04.28.1.fc9
and 3 users.  In the unsuccessful case I'm thrown back at the GDM greeter screen
instead of the desktop switched away from earlier, or, in the last attempt I got a
Unable to start new display, Could not identify the current session dialog already
when clicking on the FAS applet.
Comment 5 Ray Strode [halfline] 2008-04-29 09:52:12 EDT
Note Jakub and Martin have different issues.  Jakub only has one user on his system.
Comment 6 Jakub Jelinek 2008-04-29 10:03:36 EDT
Not anymore, for testing I've useradd(8)ed two further users, with freshly
created homes and no configuration changes whatsoever for them.  Then
unsuccessful switching attempts were both from switching to a different, but
already logged in, user, and from switching to the same user.
Comment 7 Jeremy Katz 2008-04-29 16:33:33 EDT
Did you make sure gdm was fully restarted (telinit 3;  telinit 5) after updating
gdm?
Comment 8 Jakub Jelinek 2008-04-29 16:37:01 EDT
Yes, the laptop was rebooted after upgrade.
Comment 9 Ray Strode [halfline] 2008-04-29 17:14:50 EDT
Jon found some issues related to ending up on the wrong vt because we shut down
the greeter X server after switching to the new user's VT.

He's addressing them now which will hopefully fix a lot of problems people are
seeing.
Comment 10 jmccann 2008-04-29 21:33:53 EDT
Can you please try:
http://koji.fedoraproject.org/koji/buildinfo?buildID=47636

Thanks.
Comment 11 Jakub Jelinek 2008-04-30 04:46:14 EDT
No improvement with gdm-2.21.10-0.2008.04.29.2.fc10.i386.
After some unsuccessful switching attempts I've created fresh 3 new users
(foo[345]) and rebooted.  Logging in as foo3 in gdm, type password, clicking on
Other in FUS applet, got to GDM greeter.  Click foo3 again, type password and
after short screen flicker I'm back at GDM greeter, with no user marked as
logged in.  Log in as foo3 again, click on Other in FUS applet, got Unable to
start new display/Could not identify the current session dialog and the screen
got locked.  Typed foo3's password, the dialog was still there.  Chose Lock
Screen from menu,
Switch User, got to GDM greeter, logged in as foo4, chose foo3 in FUS applet,
got locked screen for foo3 and could actually successfully switch to foo3 after
typing foo3's password.  The FUS applet doesn't mention foo4 user though, which
is logged in, only Other.  Click Other, got back Unable... dialog and locked
screen, chose Switch user.  Both foo3 and foo4 are marked in GDM Greeter as
logged in, log in as foo5.  FUS applet shows me foo3/foo4/foo5 users (foo5
grayed out), pick Other.  Now in GDM greeter only foo4 and foo5 are marked as
logged in.
Comment 12 Bill Nottingham 2008-05-02 12:30:18 EDT
At this point, I believe this is an update candidate, not a release blocker.
Comment 13 jmccann 2008-05-02 12:40:59 EDT
So there is more than one thing going on here.   The "Unable to start..."
message is due to bug #444500 .

Does it look like your x server is crashing?  That would explain why users are
no longer showing up as logged in.
Comment 14 Jakub Jelinek 2008-05-02 14:53:25 EDT
Apparently X server wasn't crashing, nor the 2.22.0-1.fc9 gdm helped.
But finally after yum updating tonight which installed:
control-center-2.22.1-4.fc9.i386
control-center-filesystem-2.22.1-4.fc9.i386
cpp-4.3.0-8.i386
evolution-2.22.1-2.fc9.i386
evolution-data-server-2.22.1-2.fc9.i386
evolution-help-2.22.1-2.fc9.i386
fedora-release-notes-9.0.0-1.noarch
firefox-3.0-0.60.beta5.fc9.i386
gcc-4.3.0-8.i386
gcc-c++-4.3.0-8.i386
gcc-gfortran-4.3.0-8.i386
gnome-desktop-2.22.1-4.fc9.i386
gnome-packagekit-0.1.12-11.20080430.fc9.i386
gnome-system-monitor-2.22.1-5.fc9.i386
gpg-pubkey-4f2a6fd2-3f9d9d3b.(none)
gpg-pubkey-db42a60e-37ea5438.(none)
hal-0.5.11-0.7.rc2.fc9.i386
hal-libs-0.5.11-0.7.rc2.fc9.i386
initscripts-8.74-1.i386
java-1.6.0-openjdk-1.6.0.0-0.10.b09.fc9.i386
java-1.6.0-openjdk-plugin-1.6.0.0-0.10.b09.fc9.i386
kdebase-runtime-4.0.3-10.fc9.i386
kdelibs-common-4.0.3-7.fc9.i386
kde-settings-4.0-22.fc9.1.noarch
kde-settings-kdm-4.0-22.fc9.1.noarch
kde-settings-pulseaudio-4.0-22.fc9.1.noarch
kernel-2.6.25-14.fc9.i686
kernel-devel-2.6.25-14.fc9.i686
kernel-headers-2.6.25-14.fc9.i386
libbonobo-2.22.0-2.fc9.i386
libdrm-2.4.0-0.11.fc9.i386
libgcc-4.3.0-8.i386
libgcj-4.3.0-8.i386
libgfortran-4.3.0-8.i386
libgomp-4.3.0-8.i386
libsemanage-2.0.25-1.fc9.i386
libsmbclient-3.2.0-1.pre3.9.fc9.i386
libstdc++-4.3.0-8.i386
libstdc++-devel-4.3.0-8.i386
lohit-fonts-bengali-2.2.1-2.fc9.noarch
lohit-fonts-gujarati-2.2.1-2.fc9.noarch
lohit-fonts-hindi-2.2.1-2.fc9.noarch
lohit-fonts-kannada-2.2.1-2.fc9.noarch
lohit-fonts-malayalam-2.2.1-2.fc9.noarch
lohit-fonts-oriya-2.2.1-2.fc9.noarch
lohit-fonts-punjabi-2.2.1-2.fc9.noarch
lohit-fonts-tamil-2.2.1-2.fc9.noarch
lohit-fonts-telugu-2.2.1-2.fc9.noarch
module-init-tools-3.4-13.fc9.i386
mousetweaks-2.22.1-2.fc9.i386
mozilla-filesystem-1.9-2.fc9.i386
NetworkManager-0.7.0-0.9.3.svn3623.fc9.i386
NetworkManager-glib-0.7.0-0.9.3.svn3623.fc9.i386
NetworkManager-gnome-0.7.0-0.9.3.svn3623.fc9.i386
openoffice.org-calc-2.4.0-12.8.fc9.i386
openoffice.org-core-2.4.0-12.8.fc9.i386
openoffice.org-draw-2.4.0-12.8.fc9.i386
openoffice.org-graphicfilter-2.4.0-12.8.fc9.i386
openoffice.org-impress-2.4.0-12.8.fc9.i386
openoffice.org-langpack-cs_CZ-2.4.0-12.8.fc9.i386
openoffice.org-langpack-en-2.4.0-12.8.fc9.i386
openoffice.org-math-2.4.0-12.8.fc9.i386
openoffice.org-writer-2.4.0-12.8.fc9.i386
openoffice.org-xsltfilter-2.4.0-12.8.fc9.i386
oxygen-icon-theme-4.0.3-10.fc9.noarch
PackageKit-0.1.12-8.20080425.fc9.i386
PackageKit-libs-0.1.12-8.20080425.fc9.i386
rhpl-0.215-3.i386
seamonkey-1.1.9-4.fc9.i386
selinux-policy-targeted-3.3.1-42.fc9.noarch
system-config-language-1.2.15-3.fc9.noarch
xorg-x11-drv-i810-2.2.1-23.fc9.i386
xorg-x11-drv-vesa-1.3.0-15.20080404.fc9.i386
xorg-x11-utils-7.3-3.fc9.i386
xulrunner-1.9-0.60.beta5.fc9.i386
yum-packagekit-0.1.12-8.20080425.fc9.i386

it works just fine.

Note You need to log in before you can comment on or make changes to this bug.