Bug 443083 - Anaconda crashes during installation of Fedora 9-Preview
Anaconda crashes during installation of Fedora 9-Preview
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
NeedsRetesting
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-04-18 11:19 EDT by eric@christensenplace.us
Modified: 2008-05-02 15:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-02 15:24:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Bug Information (86.83 KB, text/plain)
2008-04-18 11:19 EDT, eric@christensenplace.us
no flags Details

  None (edit)
Description eric@christensenplace.us 2008-04-18 11:19:32 EDT
Description of problem:
During installation of Fedora 9 (from the Fedora 9 - Preview DVD) anaconda
crashed.  It occurred during the installation of the
texlive-texmf-fonts-2007-20.fc9.noarch package.  I'm attaching the debugging report.


Additional info:
This was not a default installation.  I chose to modify what packages I wanted
added during the installation.  Also, I had problems opening the attached file.
 Vi and Nano seemed to work fine, however.
Comment 1 eric@christensenplace.us 2008-04-18 11:19:32 EDT
Created attachment 302893 [details]
Anaconda Bug Information
Comment 2 Jeremy Katz 2008-04-18 11:36:24 EDT
How big of a /tmp did you specify?
Comment 3 eric@christensenplace.us 2008-04-18 11:43:48 EDT
Oooo...  I hadn't thought about that being a problem.  I'm testing a "secure"
installation of F9 here and I only gave /tmp about 100MB (based on what I saw I
was using previously).  What should that number be?
Comment 4 Chris Lumens 2008-04-18 12:10:11 EDT
Okay, we'll just use /var/cache/yum for this stuff instead.
Comment 5 Alain Portal 2008-04-19 09:23:54 EDT
I don't know if this is relevant or not, but I could see in my anacdump.txt 
(See https://bugzilla.redhat.com/show_bug.cgi?id=443225)

....
Installation de libgdiplus-devel-1.9-4.fc9.i386
Installation de texlive-texmf-fonts-2007-20.fc9.noarch
No such file or directory
error: %post(texlive-texmf-fonts-2007-20.fc9.noarch) scriptlet failed, exit 
status 1
Installation de selinux-policy-3.3.1-35.fc9.noarch
Installation de avahi-devel-0.6.22-10.fc9.i386
....


Hope this help.
Comment 6 Bill Nottingham 2008-05-01 10:45:24 EDT
Can someone verify this fix?
Comment 7 Shawn Starr 2008-05-01 23:52:32 EDT
If we now set /var to 100MB it will fail with same msg (except different mount
point)

However, Anaconda warns is /var is less than 384MB this seems still too small
with the default package selections alone. 

Maybe mark this now as WONTFIX because if you want to shoot yourself in the
foot, you just wasted 10-15 minutes to see it fail :-)
Comment 8 Jeremy Katz 2008-05-02 15:24:27 EDT
Yep, that's the idea.  We do as much as we really can here.  And 100 megs may be
fine, it depends on your package set.

Note You need to log in before you can comment on or make changes to this bug.