This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 443085 - gvfs entries in Places aren't openable
gvfs entries in Places aren't openable
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-04-18 11:26 EDT by Bill Nottingham
Modified: 2014-03-16 23:14 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 13:25:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
a patch (6.94 KB, patch)
2008-04-19 01:17 EDT, Matthias Clasen
no flags Details | Diff
next iteration (4.49 KB, patch)
2008-04-21 00:23 EDT, Matthias Clasen
no flags Details | Diff

  None (edit)
Description Bill Nottingham 2008-04-18 11:26:43 EDT
Description of problem:

Attempting to click on them yields:

Could not open location 'archive://file%3A%2F%2F%2Fhome%2Fnotting%2Fboot.iso/'
 The default action does not support this protocol.

Version-Release number of selected component (if applicable):

gvfs-0.2.3-5.fc9.x86_64
nautilus-2.22.2-3.fc9.x86_64
gnome-panel-2.22.1.2-2.fc9.x86_64
Comment 1 Ray Strode [halfline] 2008-04-18 11:32:47 EDT
presuming this is a gvfs problem, although i don't really know.
Comment 2 David Zeuthen 2008-04-18 11:49:01 EDT
This works fine from nautilus and appears to be a valid URI and, FWIW, I can
reproduce this with latest packages. It also happens for gphoto2 uri's; I get
"Could not open location 'gphoto2://[usb:001,066]/'


Back to the panel.
Comment 3 Matthias Clasen 2008-04-19 01:17:41 EDT
Created attachment 302967 [details]
a patch
Comment 4 David Zeuthen 2008-04-19 12:45:58 EDT
Probably needs to handle G_IO_ERROR_FAILED_HANDLED in mount_async_callback() too.
Comment 5 David Zeuthen 2008-04-19 13:08:06 EDT
Matthias, please see comment 4
Comment 6 Matthias Clasen 2008-04-21 00:23:18 EDT
Created attachment 303096 [details]
next iteration

The new patch uses the already existing PanelMountOperation rather than rolling
its own, and also handles G_IO_ERROR_FAILED_HANDLED.
Comment 7 Matthias Clasen 2008-04-21 11:29:34 EDT
I'd appreciate if someone could test this patch with some more exotic mounts.
David ?
Comment 8 David Zeuthen 2008-04-21 12:41:42 EDT
Matthias, if you can build it into koji and then ping me on IRC I'll try it
right away. It shouldn't behave much different with exotic mounts but it's
always good to test stuff. Thanks.
Comment 9 Matthias Clasen 2008-04-22 14:00:54 EDT
http://koji.fedoraproject.org/koji/buildinfo?buildID=46708
has builds which should fix this. Please test.
Comment 10 Bill Nottingham 2008-04-22 14:09:48 EDT
Tested those builds, they work for me with the archive mounter. Feel free to
request a tag.
Comment 11 Martin Jürgens 2008-04-22 14:18:56 EDT
Works for me.

Note You need to log in before you can comment on or make changes to this bug.