Bug 443091 - A System Failure Has Occured
A System Failure Has Occured
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-04-18 12:11 EDT by Need Real Name
Modified: 2008-05-06 13:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 13:14:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2008-04-18 12:11:44 EDT
When I click "Update system", I sometimes get a popup message telling me a
system failure has occured. This is bad for two reasons:

1. I don't know that this message is from package kit
2. It lacks any useful information at all, and an error without information
needs to be changed or removed.

This error will terrify new users!
Comment 1 Need Real Name 2008-04-19 05:36:16 EDT
If the error pointed to the packagekit icon, it might be better.
Also, it tells me when something has completed too, which is un-unixlike.
Comment 2 Richard Hughes 2008-04-19 08:25:19 EDT
Could you post a screenshot or the text of the error please? Thanks.
Comment 3 Need Real Name 2008-04-19 08:31:18 EDT
It'll be in German - is that okay?
Comment 4 Richard Hughes 2008-04-19 08:45:30 EDT
Eeek - sorry, I'm equally rubbish at French and German; pahh, I struggle with
English and I was born here! ;-)

Can you please do:

killall gpk-update-icon
LANG=en_GB gpk-update-icon --verbose

And attach the complete output. Thanks!
Comment 5 Need Real Name 2008-04-19 08:54:27 EDT
$ LANG=en_GB gpk-update-icon --verbose
TI:14:53:27	TH:0x8c073f0	FI:pk-debug.c	FN:pk_debug_init,248
 - Verbose debugging 1 (on console 1)
TI:14:53:28	TH:0x8c073f0	FI:gpk-auto-refresh.c	FN:pk_connection_gs_changed_cb,448
 - gnome-screensaver connection-changed: 1
TI:14:53:28	TH:0x8c073f0	FI:gpk-auto-refresh.c	FN:pk_connection_gpm_changed_cb,397
 - gnome-power-manager connection-changed: 1
TI:14:53:28	TH:0x8c073f0	FI:gpk-auto-refresh.c	FN:pk_connection_gpm_changed_cb,434
 - setting on battery 0
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name
org.freedesktop.NetworkManager was not provided by any .service files
TI:14:53:28	TH:0x8c073f0	FI:pk-network-nm.c	FN:pk_network_init,146
 - ctx=0x8c643e0, id=1
TI:14:53:28	TH:0x8c073f0	FI:pk-job-list.c	FN:pk_job_list_init,241
 - no PK instance on the bus yet
TI:14:53:28	TH:0x8c073f0	FI:pk-client.c	FN:pk_client_connect,3343
 - connect
TI:14:53:28	TH:0x8c073f0	FI:pk-job-list.c	FN:pk_job_list_connect,195
 - connect
TI:14:53:28	TH:0x8c073f0	FI:gpk-watch.c	FN:pk_connection_changed_cb,825
 - connected=1
TI:14:53:28	TH:0x8c073f0	FI:gpk-watch.c	FN:gpk_watch_refresh_icon,196
 - rescan
TI:14:53:28	TH:0x8c073f0	FI:gpk-watch.c	FN:gpk_watch_refresh_icon,201
 - no activity
TI:14:53:28	TH:0x8c073f0	FI:gpk-smart-icon.c	FN:gpk_smart_icon_set_icon_name,149
 - setting icon name (null)
TI:14:53:28	TH:0x8c073f0	FI:gpk-watch.c	FN:gpk_watch_refresh_tooltip,106
 - refresh tooltip 0
TI:14:53:29	TH:0x8c073f0	FI:pk-connection.c
FN:pk_connection_connection_changed_cb,129
 - emit connection-changed: 1
TI:14:53:29	TH:0x8c073f0	FI:pk-client.c	FN:pk_connection_changed_cb,3352
 - connected=1
TI:14:53:29	TH:0x8c073f0	FI:gpk-notify.c	FN:pk_connection_changed_cb,481
 - connected=1
TI:14:53:29	TH:0x8c073f0	FI:pk-client.c	FN:pk_connection_changed_cb,3352
 - connected=1
TI:14:53:29	TH:0x8c073f0	FI:pk-job-list.c	FN:pk_connection_changed_cb,204
 - connected=1
TI:14:53:29	TH:0x8c073f0	FI:pk-client.c	FN:pk_connection_changed_cb,3352
 - connected=1
TI:14:53:29	TH:0x8c073f0	FI:pk-job-list.c	FN:pk_connection_changed_cb,204
 - connected=1
TI:14:53:29	TH:0x8c073f0	FI:gpk-watch.c	FN:pk_connection_changed_cb,825
 - connected=1
TI:14:53:29	TH:0x8c073f0	FI:gpk-watch.c	FN:gpk_watch_refresh_icon,196
 - rescan
TI:14:53:29	TH:0x8c073f0	FI:gpk-watch.c	FN:gpk_watch_refresh_icon,201
 - no activity
TI:14:53:29	TH:0x8c073f0	FI:gpk-smart-icon.c	FN:gpk_smart_icon_set_icon_name,149
 - setting icon name (null)
TI:14:53:29	TH:0x8c073f0	FI:gpk-watch.c	FN:gpk_watch_refresh_tooltip,106
 - refresh tooltip 0
TI:14:53:29	TH:0x8c073f0	FI:gpk-auto-refresh.c
FN:gpk_auto_refresh_network_changed_cb,340
 - setting online 1
TI:14:53:29	TH:0x8c073f0	FI:gpk-auto-refresh.c	FN:gpk_auto_refresh_change_state,272
 - not when this early in the session

Comment 6 Richard Hughes 2008-04-20 11:21:52 EDT
Sorry, I should have been more clear. Could you please do:

killall gpk-update-icon
LANG=en_GB gpk-update-icon --verbose

And then reproduce the error. I need to see the error in the debug output. Thanks.
Comment 7 Will Woods 2008-04-26 13:04:06 EDT
PackageKit-0.1.12-7.20080425.fc9 is now available - could you update to that and see if you can 
reproduce the error as requested in comment #6? We can't seem to reproduce it here.
Comment 8 Will Woods 2008-04-28 18:12:36 EDT
No response from the reporter, and I've tried all sorts of things to reproduce
the problem with no luck.

Dropping from blocker until we have some way of tracing/reproducing the problem.
Comment 9 Need Real Name 2008-04-29 13:21:03 EDT
I'm waiting for the problem to happen again so I can update the bug. Maybe it's
fixed, or it was fighting with yum-updatesd?
Comment 10 Will Woods 2008-04-29 13:39:38 EDT
Richard seemed to think the problem was fixed. If you haven't been able to
reproduce it with the current PackageKit packages, we should probably close this
bug. You can always reopen it if it *does* come back.

As for yum-updatesd.. it shouldn't be running anymore. We might need to open a
bug about the fact that it isn't obsoleted on upgrade.

Note You need to log in before you can comment on or make changes to this bug.