Bug 443099 - original nvidia driver segfaults (signal 11) on x session switch
original nvidia driver segfaults (signal 11) on x session switch
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-18 12:30 EDT by Mathias Panzenböck
Modified: 2008-04-19 03:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-19 03:50:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mathias Panzenböck 2008-04-18 12:30:39 EDT
Description of problem:
I have the original nvidia drivers installed (I have a GeForce 8800) and most of
the time two people are graphically logged in on my computer: my mother and me.
Sometimes when my mother switches the logins with ctrl+alt+f7/f9 MY session
crashes. Not her. When I switch I never experienced a crash. It happens most
when I have a lot of programs open: KDE, firefox (with a lot of tabs),
thunderbird, eclipse, gvim, amarok, kopete and gkrellm.

This might be a nvidia issue, but with the same driver (but another video card:
GeForce 4400) under Ubuntu I had never a crash. So maybe it isn't a nvidia issue
after all?

Version-Release number of selected component (if applicable):
xorg: 7.3
nvidia driver: happens with both 171.06 and 169.12

How reproducible:
Often.

Steps to Reproduce:
1. graphical login user A
2. graphical login user B
3. do stuff (work with firefox, eclipse, etc.)
4. switch between logins
  
Actual results:
X session crashes.

Expected results:
Switched login.

Additional info:
I lost the corresponding Xorg log. When it's happening the next time I will
upload it here. The signal 11 is raised in
/usr/lib/xorg/modules/drivers/nvidia_drv.so, that I can remember.
Comment 1 Matěj Cepl 2008-04-19 03:50:14 EDT
Thanks for the report. We are sorry that we cannot help you with your problem,
but we are not able to support binary-only drivers. If you would be able to
reproduce this issue using only open source software, please, reopen this bug
with the additional information, but in meantime I have no choice than to close
this bug as CANTFIX (because we really cannot fix it).

For users who are experiencing problems installing, configuring, or using the
unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides
indirect customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and passes them on to
Nvidia engineers for investigation.  Once they've isolated a particular problem,
it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have
experienced the particular problem may be able to assist.  If there is a real
bug occuring, Nvidia will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system releases that they
officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring
technical support may also find the various X.Org, XFree86, and Red Hat mailing
lists helpful in finding assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Note You need to log in before you can comment on or make changes to this bug.