Bug 443122 - F9PR x86_64 Live KDE: resolution not usable
F9PR x86_64 Live KDE: resolution not usable
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vesa (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-18 14:10 EDT by Sandro Mathys
Modified: 2009-07-14 14:26 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 14:26:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
KDE 4 with unusable resolution. (756.02 KB, image/jpeg)
2008-04-18 14:10 EDT, Sandro Mathys
no flags Details
KDE4 starting with unusable resolution. (747.08 KB, image/jpeg)
2008-04-18 14:11 EDT, Sandro Mathys
no flags Details
rhgb with unusable resolution. (656.21 KB, image/jpeg)
2008-04-18 14:12 EDT, Sandro Mathys
no flags Details
after logout (562.42 KB, image/jpeg)
2008-04-18 14:13 EDT, Sandro Mathys
no flags Details
grub working fine (775.50 KB, image/jpeg)
2008-04-18 14:14 EDT, Sandro Mathys
no flags Details
Xorg.0.log (43.55 KB, text/plain)
2008-04-19 04:40 EDT, Sandro Mathys
no flags Details
dmesg (38.29 KB, text/plain)
2008-04-19 04:41 EDT, Sandro Mathys
no flags Details
lsmod (3.74 KB, text/plain)
2008-04-19 04:42 EDT, Sandro Mathys
no flags Details
lspci (2.18 KB, text/plain)
2008-04-19 04:42 EDT, Sandro Mathys
no flags Details

  None (edit)
Description Sandro Mathys 2008-04-18 14:10:12 EDT
Description of problem:
I just booted F9PR (x86_64 Live KDE) on my Dell Inspiron 1720 and it was
anything but usable. The resolution is so small, even rhgb gets messed up (puts
the progress bar over the artwork). The pixels are that big, I can't read things
written in normal font size (KDE menu, display settings dialogs), because one
letter consists only of a few pixels.

Well, I really can't read something, so its hard to find anything out.


How reproducible:
Always.

Steps to Reproduce:
1. Boot LiveCD
2. "Enjoy"
  
Actual results:
Resolution unusable

Expected results:
At the very least 800x600, better 1024x768. 1920x1200 supported by hardware (and
working fine with nVidia's proprietary driver and F8). I remember to have F8
working without the proprietary driver as well - can't remember the resolution
back then, tho...but it was usable.

Additional info:
I then tried to logout, which resulted in a black screen with some pink/white
blinking bars (not always the same size/position/etc).

Oh, the component is a wild guess. I don't know which driver was used.
Comment 1 Sandro Mathys 2008-04-18 14:10:13 EDT
Created attachment 302915 [details]
KDE 4 with unusable resolution.
Comment 2 Sandro Mathys 2008-04-18 14:11:27 EDT
Created attachment 302916 [details]
KDE4 starting with unusable resolution.
Comment 3 Sandro Mathys 2008-04-18 14:12:00 EDT
Created attachment 302918 [details]
rhgb with unusable resolution.
Comment 4 Sandro Mathys 2008-04-18 14:13:16 EDT
Created attachment 302919 [details]
after logout

laptop switches off after some time (<1min), tho.
Comment 5 Sandro Mathys 2008-04-18 14:14:46 EDT
Created attachment 302920 [details]
grub working fine

...ok, that's been the last image. sorry for the bad quality, they've been made
with my mobile phone.

uh, I forgot to mention, that I didn't boot from CD but from liveUSB...sorry.
no persistence, tho.
Comment 6 Matěj Cepl 2008-04-19 04:01:01 EDT
Even though you have no true persistence is available you should be able to get
some files stored somewhere (scp, ftp, another USB drive, something). So, would
you be able to attach your X server config file (/etc/X11/xorg.conf) and X
server log file (/var/log/Xorg.*.log, or maybe something in /tmp, I am not sure)
to the bug report as individual uncompressed file attachments using the bugzilla
file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 7 Sandro Mathys 2008-04-19 04:40:15 EDT
Created attachment 302979 [details]
Xorg.0.log

Xorg.0.log shows that no config file was loaded, and indeed. there's been no
xorg.conf. Even tried updatedb && locate xorg.conf and it only showed the man
page.
Comment 8 Sandro Mathys 2008-04-19 04:41:36 EDT
Created attachment 302980 [details]
dmesg

maybe some other infos will help, so I'll attach what came to my mind.

btw. the vt is working/usable, so I can do cmd line stuff to help solve this.
Comment 9 Sandro Mathys 2008-04-19 04:42:17 EDT
Created attachment 302981 [details]
lsmod
Comment 10 Sandro Mathys 2008-04-19 04:42:35 EDT
Created attachment 302982 [details]
lspci
Comment 11 Sandro Mathys 2008-04-19 04:44:41 EDT
Comment on attachment 302981 [details]
lsmod

actually this is the lsmod output. the "messages" file seems to be empty.
Comment 12 Adam Jackson 2008-04-25 13:59:08 EDT
Your laptop is made of lies:

(II) NV(0): LVDS native size 738x414

So we try to pick a mode that fits in that size.

What's the output of 'hexdump -C /proc/acpi/video/*/*/EDID' ?
Comment 13 Sandro Mathys 2008-04-25 17:32:33 EDT
How does it come then, that it worked fine with F8?

I've executed the above within my installed F8 and not within the live system, I
hope that's ok. Just tell me otherwise. Output is:
$ hexdump -C /proc/acpi/video/*/*/EDID
00000000  3c 6e 6f 74 20 73 75 70  70 6f 72 74 65 64 3e 0a  |<not supported>.|
*
00000080
Comment 14 Bug Zapper 2008-05-14 05:40:10 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Bug Zapper 2009-06-09 20:15:56 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Bug Zapper 2009-07-14 14:26:44 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.