Bug 443168 - Can not automount flash drive
Can not automount flash drive
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-mount (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-04-18 17:58 EDT by Nicolas Mailhot
Modified: 2013-03-05 22:55 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-19 12:53:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Nonsensical popup (39.32 KB, image/png)
2008-04-18 18:01 EDT, Nicolas Mailhot
no flags Details
system lshal (157.07 KB, text/plain)
2008-04-18 18:03 EDT, Nicolas Mailhot
no flags Details

  None (edit)
Description Nicolas Mailhot 2008-04-18 17:58:35 EDT
Description of problem:

When I plug in a multi-card reader with a factory-formatted compact flash card
in I'm greeted with a nonsensical popup. Trying to click on the flash name in
the gnome shortcuts menu results in a similar popup. mounting it as root on the
CLI works fine (mount -t auto /dev/sde1 /mnt/)

Version-Release number of selected component (if applicable):
gnome-mount-0.8-1.fc9.x86_64

How reproducible:
Always
Comment 1 Nicolas Mailhot 2008-04-18 18:01:25 EDT
Created attachment 302947 [details]
Nonsensical popup
Comment 2 Nicolas Mailhot 2008-04-18 18:03:38 EDT
Created attachment 302948 [details]
system lshal
Comment 3 David Zeuthen 2008-04-18 18:52:55 EDT
Try this 'gnome-mount -v -t -b -d /dev/sde1' and paste the output (ensure sde1
isn't mounted before trying it)
Comment 4 Nicolas Mailhot 2008-04-19 04:24:03 EDT
Here you go

$ gnome-mount -v -t -b -d /dev/sde1
gnome-mount 0.8
** (gnome-mount:26946): DEBUG: Mounting
/org/freedesktop/Hal/devices/volume_uuid_FC30_3DA9
** (gnome-mount:26946): DEBUG: read mount point '/media/CompactFlash' from gconf
string key
'/system/storage/drives/_org_freedesktop_Hal_devices_storage_serial_Generic_USB_CF_Reader_058F63626376_0_1/mount_point'
** (gnome-mount:26946): DEBUG: read default option 'shortname=lower' from gconf
strlist key /system/storage/default_options/vfat/mount_options
** (gnome-mount:26946): DEBUG: read default option 'uid=' from gconf strlist key
/system/storage/default_options/vfat/mount_options
** (gnome-mount:26946): DEBUG: Mounting
/org/freedesktop/Hal/devices/volume_uuid_FC30_3DA9 with
mount_point='/media/CompactFlash', fstype='', num_options=2
** (gnome-mount:26946): DEBUG:   option='shortname=lower'
** (gnome-mount:26946): DEBUG:   option='uid=500'
** Message: Mount failed for /org/freedesktop/Hal/devices/volume_uuid_FC30_3DA9
org.freedesktop.Hal.Device.Volume.UnknownFailure : mount_point cannot contain
the following characters: newline, G_DIR_SEPARATOR (usually /)
Comment 5 David Zeuthen 2008-04-19 12:53:17 EDT
> ** (gnome-mount:26946): DEBUG: read mount point '/media/CompactFlash' from
gconf string key

From the gnome-mount man page

       -m, --mount-point
              Specify mount point to use; don’t  include  /media  as  this  is
              automatically  appened  by the mechanism used to mount, e.g. the
              HAL methods.

Maybe you set the mount point from the Nautilus extension UI (which I agree is
somewhat suboptimal / crappy but that's a separate bug and partly why it's not
in the default install) and it didn't warn you that slash isn't allowed.

Just changing the key from /media/CompactFlash to CompactFlash should work. Or
better, just delete the gconf bits for this drive and just change the fs label
to be CompactFlash. Then this will work automatically without having to mess
around with gconf settings and whatnot.

Hope this helps.
Comment 6 Nicolas Mailhot 2008-04-19 13:15:31 EDT
(In reply to comment #5)
> Or
> better, just delete the gconf bits for this drive and just change the fs label
> to be CompactFlash. Then this will work automatically without having to mess
> around with gconf settings and whatnot.

Since I never saw the extension you talk of and besides never had a compact
flash media before I sort of doubt I added this key manually, but whatever added
it is gone now and removing the gconf key works, thank you very much. 

Note You need to log in before you can comment on or make changes to this bug.