Bug 443176 - AR5006EG/AR5007EG not supported by ath5k
AR5006EG/AR5007EG not supported by ath5k
Status: CLOSED DUPLICATE of bug 254192
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-04-18 18:51 EDT by Charlie Wyse
Modified: 2008-05-29 10:25 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-29 10:25:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Charlie Wyse 2008-04-18 18:51:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv: Gecko/20080325 Red Hat/ Firefox/

Description of problem:
I have a HP Pavillion DV9700 Notebook with an Atheros AR5007EG card (Displayed as AR5006EG, which according to most forums is false).  When I try to load the ath5k module which at least loaded the wlan0 interface with the default Fedora core on the FC8-x86_64 disk, I get that this device is not supported.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Update to latest version of Fedora 8
2. Run ifconfig -a
3. Notice that no wlan0 or ath0 is created
4. run modprobe ath5k
5. Notice the errors in dmesg.

Actual Results:
ACPI: PCI Interrupt Link [LK4E] enabled at IRQ 19
ACPI: PCI Interrupt 0000:03:00.0[A] -> Link [LK4E] -> GSI 19 (level, low) -> IRQ 19
PCI: Setting latency timer of device 0000:03:00.0 to 64
ath5k_pci 0000:03:00.0: registered as 'phy0'
ath5k phy0: Device not yet supported.
ACPI: PCI interrupt for device 0000:03:00.0 disabled

Expected Results:
I should be able to get on the internet and surf the tubes.

Additional info:
I also tried madwifi to get this to work and that pretty much failed.  I even sucked it up and attempted ndiswrappers, as you can guess from me opening this ticket.  That failed as well.
Comment 1 Charlie Wyse 2008-04-18 18:52:50 EDT
Here is an lspci -vvv of the device for more information.  Let me know if I can
provide anything else.  Also I included the url to the madwifi ticket as they
seem to be working on the issue as well.  But I would rather use a redhat kernel
module instead of a madwifi module or ndiswrappers.

03:00.0 Ethernet controller: Atheros Communications, Inc. AR5006EG 802.11 b/g
Wireless PCI Express Adapter (rev 01)
        Subsystem: Hewlett-Packard Company Unknown device 137a
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-
        Interrupt: pin A routed to IRQ 19
        Region 0: Memory at f6000000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0
                Address: fee0300c  Data: 41a1
        Capabilities: [60] Express (v1) Legacy Endpoint, MSI 00
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns,
L1 <64us
                        ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                        RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
                        MaxPayload 128 bytes, MaxReadReq 512 bytes
                DevSta: CorrErr- UncorrErr+ FatalErr- UnsuppReq+ AuxPwr- TransPend-
                LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency
L0 <512ns, L1 <64us
                        ClockPM- Suprise- LLActRep- BwNot-
                LnkCtl: ASPM L1 Enabled; RCB 128 bytes Disabled- Retrain- CommClk+
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+
DLActive- BWMgmt- ABWMgmt-
        Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
                Vector table: BAR=0 offset=00000000
                PBA: BAR=0 offset=00000000
        Kernel modules: ath_pci, ath5k
Comment 2 Nathan Crubel 2008-05-08 21:56:46 EDT
I am getting the same problem.  Keep saying the wlan0 link not ready.  I am have
an Acer 7520 with the Atheros AR5006EG 802.11 b/g wireless PCI Express adaptor
also.  I have tried madwifi and ndiswrapper.  Keep getting the same error and no
Comment 3 Nathan Crubel 2008-05-08 21:57:24 EDT
I am also getting the same error on an Acer 4520 with the same wireless.  
Comment 4 John W. Linville 2008-05-29 10:25:32 EDT

*** This bug has been marked as a duplicate of 254192 ***

Note You need to log in before you can comment on or make changes to this bug.