Bug 443182 - Installer crashed when installing live cd to disk
Installer crashed when installing live cd to disk
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-04-18 20:47 EDT by Mathirajan S. Manoharan
Modified: 2008-10-31 13:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-10-31 10:08:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
InstallError.txt (6.65 MB, text/plain)
2008-04-18 20:48 EDT, Mathirajan S. Manoharan
no flags Details

  None (edit)
Description Mathirajan S. Manoharan 2008-04-18 20:47:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv: Gecko/20080118 Firefox/

Description of problem:
boot with fedora 9 live cd
install to a disk with pre created partition (partition1: fat32, partition2 : swap, partition : ext3)
installer reports unhandled exception and exits.

Version-Release number of selected component (if applicable):
fedore 9 refresh

How reproducible:

Steps to Reproduce:
1.boot with fedora 9 live cd
2.install to a disk with pre created partition (partition1: fat32, partition2 : swap, partition : ext3)
3.installer reports unhandled exception and exits.

Actual Results:
installer writes the contents to file and exits.

Expected Results:
installer should have installed fedora

Additional info:
i have the InstallError.txt. Where do I post it? It's ~5 mb in size.
Comment 1 Mathirajan S. Manoharan 2008-04-18 20:48:42 EDT
Created attachment 302962 [details]

This is the file written by Installer when it exited.
Comment 2 Rich Megginson 2008-04-18 23:04:53 EDT
I'm not sure where this goes, so I'm moving it to anaconda.
Comment 3 Chris Lumens 2008-04-20 16:31:17 EDT
Did you verify that your download and burn are correct?  This sounds like bad
media to me.
Comment 4 Mathirajan S. Manoharan 2008-04-21 16:46:36 EDT
yes. when booting the live cd also, I selected "verify and boot" which booted
fine with out any problem.

is there any other way to verify if the burn is correct?
Comment 5 Jeremy Katz 2008-04-22 15:05:12 EDT
That's the main way.  Can you try adding 'libata.dma=0' to your kernel command
line?  It'll be slower, but it will help to pin down if DMA is the problem
Comment 6 Mathirajan S. Manoharan 2008-04-23 19:36:34 EDT
tried with 'libata.dma=0'
still get the same exception. no difference.
Comment 7 Chuck Ebbert 2008-05-02 06:56:48 EDT
How is this a kernel bug?
Comment 8 Bill Nottingham 2008-05-02 13:18:04 EDT
It's getting I/O errors reading a valid livecd.
Comment 9 Jens Petersen 2008-05-08 01:12:44 EDT
I just rolled a x86_64 Live image here from latest rawhide , booted it from usb and
installed from it fine FWIW.
Comment 10 Bill Nottingham 2008-05-09 13:15:24 EDT
Removing from blocker, we could not reproduce this and are not holding the
release for it.
Comment 11 Bug Zapper 2008-05-14 05:41:25 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 12 Geri Broser 2008-10-28 05:17:43 EDT
Get the same error with the latest F9 Desktop Live-CD: http://fedora.pastebin.com/m1b396629

1. Put the i686-Live-CD to USB.
2. System starts and works like a charm.
3. Selected „Install to Hard drive”
4. After entering all the necessary information the installation starts and crashes at about 80%.

Do you need any further information? HW? What I specified in the installer?
Comment 13 Chuck Ebbert 2008-10-31 03:39:06 EDT
Why is this filed as a kernel bug?
Comment 14 Geri Broser 2008-10-31 09:41:14 EDT
The error doesn't occur with F10 Beta Desktop Live-CD any longer. (At least on my IBM TP T30.)

Note You need to log in before you can comment on or make changes to this bug.