Bug 443184 - bad error message and behaviour when installing on USB disk with mounted partition
bad error message and behaviour when installing on USB disk with mounted part...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: StringChange
Depends On:
Blocks: AnacondaStorage
  Show dependency treegraph
 
Reported: 2008-04-18 21:23 EDT by Peter F. Patel-Schneider
Modified: 2009-07-16 09:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-16 09:54:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter F. Patel-Schneider 2008-04-18 21:23:48 EDT
Description of problem:

Poor error reporting and behaviour when install USB disk has mounted partition

Version-Release number of selected component (if applicable):

Version in Fedora 9 Preview

How reproducible:

Always (3 of 3)

Steps to Reproduce:
1. Start machine with Fedora-9-Preview live on USB stick, install disk in
external USB enclose containing a previous Fedora install (boot and LVM partitions)
2. Note that install disk boot partition is mounted.
3. Install to hard drive, using defaults throughout.
  
Actual results:

Error box with: An error occurred trying to format sdb1. ...
Disk has been modified.

Expected results:

Error box saying something like:  Can't install over mounted partition.
No change to disk.

Additional info:

Not a big problem, but the error message is soo generic!

Can proceed by just unmounting the partition and starting install from the
beginning.
Comment 1 Bug Zapper 2008-05-14 05:41:31 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Peter F. Patel-Schneider 2008-09-25 12:21:02 EDT
This behaviour is still happening with
http://alt.fedoraproject.org/pub/alt/stage/10-Beta-Spins/i686/
     F10-Beta-i686-Live.iso        as of 24 Sept 7:26pm EDT

Still low priority, I guess
Comment 3 Bug Zapper 2008-11-25 21:13:01 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Andy Lindeberg 2009-07-09 15:56:28 EDT
Our storage code has been almost completely rewritten since this bug was filed. Can you test with F11 and let us know if the error message is still vague? If so, we're doing a rewrite of error messages very soon, so let me know and I'll make sure it gets looked at.
Comment 5 Peter F. Patel-Schneider 2009-07-10 07:24:29 EDT
The conditions for this bug are rather specific, so I may not be able to recreate the environment for a while, but I'll try to test this out as soon as possible.
Comment 6 Peter F. Patel-Schneider 2009-07-15 19:55:55 EDT
This is fixed.

The storage code helpfully unmounts the file systems before attempting to install.
Comment 7 Chris Lumens 2009-07-16 09:54:35 EDT
Thank you for retesting.

Note You need to log in before you can comment on or make changes to this bug.