Bug 443194 - Strife is unplayable
Strife is unplayable
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vavoom (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-19 03:01 EDT by Conrad Meyer
Modified: 2008-06-25 13:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-25 13:41:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Conrad Meyer 2008-04-19 03:01:04 EDT
Description of problem:
When you play the Strife demo, the guard in the very first level is supposed 
to drop a key to let you out the locked door. This never happens.


Version-Release number of selected component (if applicable):
1.24-3


How reproducible:
Always.

Steps to Reproduce:
1. Run strife from the menu.
2. Agree to download the demo wad.
3. Kill the guard in the first level.
  
Actual results:
Dead body on the floor.


Expected results:
Dead body on the floor with a key in/on it.


Additional info:
This seems like a bug to me.
Comment 1 Hans de Goede 2008-04-19 03:23:05 EDT
Thanks for reporting this. I can reproduce the problem. Since upstream is very
active, and I don't know the code to well I've mailed upstream (no bugtracker)
with this problem, as soon as they make a fix available I'll update the Fedor
packages to include the fix.

So now we wait.
Comment 2 Conrad Meyer 2008-04-19 03:36:56 EDT
Cool, thanks for the quick reply.
Comment 3 Conrad Meyer 2008-04-19 20:34:15 EDT
I've also had vavoom just die on me a number of times, but I'm not sure how to 
reproduce that reliably (it's never at the same place/time/difficulty etc).
Comment 4 Hans de Goede 2008-04-20 02:01:01 EDT
(In reply to comment #3)
> I've also had vavoom just die on me a number of times, but I'm not sure how to 
> reproduce that reliably (it's never at the same place/time/difficulty etc).

The vavoom you have is rather old, can you try building the latest srpm:
http://koji.fedoraproject.org/packages/vavoom/1.27.1/1.fc9/src/vavoom-1.27.1-1.fc9.src.rpm

And see if that improve things? I'm normally reluctant to update vavoom within a
Fedora release, because as said upstream is rather active (iow lots of changes)
and they sometimes introduce regressions, but if 1.24 crashes for you and 1.27.1
does not then that sounds like a good reason to upgrade.

Comment 5 Conrad Meyer 2008-04-20 03:01:25 EDT
I managed to play through the entire demo without saving (i.e. no crashes) with 
1.27.1-1. Didn't notice any regression-like behavior. I'll stay with 1.27.1 for 
now :).
Comment 6 Conrad Meyer 2008-04-20 04:20:53 EDT
Oh, just got it to crash again :). I've mostly noticed it crashing right as I 
hit the end-of-level switches (this time was at the end of the Phobos Lab 
level, E1M5).
Comment 7 Hans de Goede 2008-06-25 13:41:19 EDT
upstream says this is fixed in 1.28, which is in rawhide now, closing.

Note You need to log in before you can comment on or make changes to this bug.