Bug 443206 - system-config-network does not start always from non root login
system-config-network does not start always from non root login
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-19 05:03 EDT by n_k_samal
Modified: 2008-04-21 08:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 08:31:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description n_k_samal 2008-04-19 05:03:01 EDT
Description of problem:
The root user generally works by logging as ordinary user. In cases of need the 
root user does a "su root" or enters the root password when asked by gui tool 
system-config-network and carries out necessary configuration changes. Most of 
the time the system does not respond when the root user tries to use the 
graphical gui tool system-config-network.

Version-Release number of selected component (if applicable):
Fedora-9-Beta-i386

How reproducible:
Log in as root and run the gui tool system-config-network from applications


Steps to Reproduce:
1.Log in as ordinary uses
2.Go to applications > network.
3.Press enter
4.If no response for about 20 seconds log out and re-login again as non root 
user and repeat steps 2 and 3
5. If no response try step 4 once again.
6. After two /three/four trials the system asks to enter root password.
7. Now necessary changes can be made.

  
Actual results:
Most of the times no response.


Expected results:
The system should have asked the non root user to enter root password on the 
first time itself since he does not has the required privilages.


Additional info:
Full system profile is at http://www/smolt.org/show?/uuid=pub_85955a62-7804-
46c3-9010-eb5cf098549a.
No such problem was seen in F7 where every time the graphical GUI tools system-
config-network was invoked by not root user, the system used to ask for root 
password. Once root password was entered necessary changes could be made.
Comment 1 John Poelstra 2008-04-19 16:13:08 EDT
Since this is reported as a bug in the beta version which is several weeks old,
could you 'yum update' to the latest packages and try this scenario again to see
if it still exists?  There may have been some previous issues, now resolved,
that were affecting this.

Thanks for your help.

Comment 2 n_k_samal 2008-04-20 02:25:18 EDT
OK, I will yum update system-config-network and find out if the problem exixts 
or not. I will post the results tomorrow.
Comment 3 n_k_samal 2008-04-21 04:43:58 EDT
I have yum updated system-config-network and now the problem does not exist.
Thanks for your help.

Note You need to log in before you can comment on or make changes to this bug.