Bug 443207 - system-config-services does not always respond from non root logins
system-config-services does not always respond from non root logins
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
9
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-19 05:12 EDT by n_k_samal
Modified: 2008-08-16 22:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-16 22:33:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description n_k_samal 2008-04-19 05:12:34 EDT
Description of problem:
The root user generally works by logging as ordinary user. In cases of need the 
root user does a "su root" or enters the root password when asked by gui tool 
system-config-services and carries out necessary configuration changes. Most of 
the time the system does not respond when the root user tries to use the 
graphical gui tool system-config-services.

Version-Release number of selected component (if applicable):
Fedora-9-Beta-i386

How reproducible:
Log in as root and run the gui tool from system-config-services from 
applications menu.

Steps to Reproduce:
1.Log in as ordinary uses
2.Go to applications > services.
3.Press enter
4.If no response for about 20 seconds log out and re-login again as non root 
user and repeat steps 2 and 3
5. If no response try step 4 once again.
6. After two /three/four trials the system asks to enter root password.
7. Now necessary changes can be made.
  
Actual results:
Most of the times no response.

Expected results:
The system should have asked the non root user to enter root password on the 
first time itself since he does not has the required privilages.

Additional info:
Full system profile is at http://www/smolt.org/show?/uuid=pub_85955a62-7804-
46c3-9010-eb5cf098549a.
No such problem was seen in F7 where every time the graphical GUI tool system-
config-services was invoked by not root user, the system used to ask for root 
password. Once root password was entered necessary changes could be made.
Comment 1 Nils Philippsen 2008-04-22 11:47:39 EDT
I can't reproduce that. Would you please describe your environment in more
detail? For instance you say that you start the tool by going to "applications >
services" -- I'm using GNOME and the tool is at "System > Administration >
Services", what desktop environment do you use?
Comment 2 n_k_samal 2008-04-24 09:25:44 EDT
I am sorry, there was some typing error as I had posted the bug from another
machine since the machine running F-9-Beta was giving lots of problems. 

As you have rightly told the the tool is at "System > Administration >
Services." and not "applications > services ".

I am using Gnome. 

I did one yum update and now it is working fine. However the full gui window
(Service Configuration )takes a lot more time to appear when compared to F-7
running on the same machine.

Thanks for your help.
Comment 3 Bug Zapper 2008-05-14 05:42:36 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Kevin 2008-08-16 22:33:31 EDT
Original issue resolved after update as per reporters notes.

Please file a new bug report if the window is still taking an excessive amount of time to load.

Note You need to log in before you can comment on or make changes to this bug.