Bug 443212 - incorrect and/or agressive optimization compile problem
incorrect and/or agressive optimization compile problem
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-19 06:15 EDT by Thomas Janssen
Modified: 2008-04-20 12:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-19 22:39:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Janssen 2008-04-19 06:15:56 EDT
Description of problem:
I cannot run any Python-based desklet: I get garbage collection errors!
If you get errors similar to:

python: Modules/gcmodule.c:275: visit_decref: Assertion `gc->gc.gc_refs != 0'
failed.
     Aborted

It means your installment of Python has a corrupted garbage collector;
it is often caused by incorrect or aggressive optimization during the
compilation.

See this as well: http://article.gmane.org/gmane.linux.redhat.fedora.mentors/16

Version-Release number of selected component (if applicable):
python-2.5.1-15.fc8

How reproducible:
Just start a python Desklet: http://adesklets.sourceforge.net/desklets.html

Steps to Reproduce:
1. Start a desklet
2.
3.
  
Actual results:
python: Modules/gcmodule.c:275: visit_decref: Assertion `gc->gc.gc_refs != 0'
failed.
     Aborted

Expected results:
Working Desklets

Additional info:
Compiled adesklets from http://sourceforge.net/project/showfiles.php?group_id=126227
Same adesklets, desklets works perfect in Debian Lenny in a VM (Virtualbox).
Comment 1 James Antill 2008-04-19 19:26:39 EDT
 Is this gdesklets? I'll reassign assuming yes.

 I know there's been at least one bug in the gnome python stack, maybe the
problem is there ... it's almost guaranteed that this isn't a generic python bug.
Comment 2 Tyler Owen 2008-04-19 20:53:08 EDT
This is not a gdesklets related issue.  Reporter has compiled adesklets from
source and adesklets won't run b/c of the way python is compiled/optimized
(according to the adesklets site)???

Assigning back to python component since it is not gdesklets related and
adesklets is not part of the Fedora Collection



Comment 3 Luya Tshimbalanga 2008-04-19 22:17:18 EDT
Reassigning the bug to the right maintainer.
Comment 4 James Antill 2008-04-19 22:39:24 EDT
 Ok, I understand now ... "adesklets" is an external package and has a bug.
Comment 5 James Antill 2008-04-19 22:43:35 EDT
 To give some more help, if the adesklets people have a bug logged against
_upstream_ python ... and there is an acknowledged code problem and/or
optimization problem in python, feel free to paste it and I'll see what I can do
to help you in Fedora ... until then, I'm going to assume adesklets is broken.
Comment 6 Thomas Janssen 2008-04-20 07:06:12 EDT
Hello James,

no, the adesklets people have not logged a bug against upstream python. It was
from http://article.gmane.org/gmane.linux.redhat.fedora.mentors/16
That was everything trouble related to adesklets that i have found with google.

adesklets itself runs fine with, example, Debian Lenny (running in Vbox as
Guest, Fedora 8 as Host). It seems that Fedora is the only Distribution where it
has trouble. I have filed the bug because i dont like to recompile a stock
Python from python.org for myself. And i thought it would be great to have
adesklets working in Fedora 9, if you or the Mentor (from the link above) know
what is incorrect or too aggressive optimized, so that i can make a adesklets
rpm for Fedora and maintain it eventually.

If you need more info, tell me. If it is unworthy for you, tell me also please.

Thank you for your time.
Comment 7 James Antill 2008-04-20 12:52:01 EDT
""" incorrect or too aggressive optimized """

 Again, as far as I know there is nothing "incorrect" or "too aggressively
optimized" in python ... as far as I can tell these are just words from the
adesklets developers that mean "we have a bug in our code that goes away if we
recompile python without optimizations".

 To put it another way, I see a _lot_ of these "GC bugs in python" and I have
yet to see one that is actually a python bug. So without some kind of real data,
this is just another buggy python extension which you are free to try and run or
not.

Note You need to log in before you can comment on or make changes to this bug.