Bug 443226 - ati9250 and Fedora-9-Preview-i686-Live.iso
ati9250 and Fedora-9-Preview-i686-Live.iso
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
9
i686 Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-19 09:21 EDT by Nicola Ricciarelli
Modified: 2009-07-14 13:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 13:28:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of dmesg (20.50 KB, text/plain)
2008-04-21 18:21 EDT, Matěj Cepl
no flags Details
Xorg.0.log from Slackware (36.61 KB, text/plain)
2008-04-21 18:22 EDT, Matěj Cepl
no flags Details
xorg.conf from Slackware (14.39 KB, text/plain)
2008-04-21 18:22 EDT, Matěj Cepl
no flags Details
dmesg - Fedora-9-Preview-i386-DVD (18.05 KB, text/plain)
2008-04-22 08:36 EDT, Nicola Ricciarelli
no flags Details
Xorg.0.log - Fedora-9-Preview-i386-DVD (26.83 KB, text/plain)
2008-04-22 08:37 EDT, Nicola Ricciarelli
no flags Details
xorg.conf - Fedora-9-Preview-i386-DVD (594 bytes, text/plain)
2008-04-22 08:38 EDT, Nicola Ricciarelli
no flags Details

  None (edit)
Description Nicola Ricciarelli 2008-04-19 09:21:24 EDT
Description of problem:


Version-Release number of selected component (if applicable):
Ati radeon 9250  
Fedora-9-Preview-i686-Live.iso
Monitor: Sony Multiscan g200

How reproducible:
100%

Steps to Reproduce:
1. boot the system using the bootable cd
2.
3.
  
Actual results:
it starts to boot the system than it turn off the monitor and place it in
power-saving state. And here the bootinb process stops.

Expected results:
finish booting the system and showing the login window

Additional info:
Comment 1 Matěj Cepl 2008-04-21 11:34:02 EDT
Do you have another computer? Then you might be able to get to the computer via
ssh and copy to your other computer log files which are either
/var/log/Xorg.*.log or (if we haven't got to that stage) in /tmp/X*.

Or, alternatively, could you please start in the text mode and possibly add 3 to
the kernel command line, so that you should end up in the CLI mode. Then login
as a user guest and run command startx? Resulting disaster would be again logged
in /var/log/Xorg.*.log (much less likely this time, that it would be in /tmp/X*.

Please attach these logs files (collected by whichever method) and your X server
config file (/etc/X11/xorg.conf) to the bug report as individual uncompressed
file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Matěj Cepl 2008-04-21 18:20:48 EDT
Please, use bugzilla only for further communication:

Hi Matej,
This pc I'm using it runs  windows xp, It's not my own pc .. i've asked to
change to lin and awaiting for the ok.
The pc I've had the problem instead is my home pc.
I was courious to see the new fedora9 I've burned the live cd
Fedora-9-Preview-i686-Live.iso
Immediately after choosing to boot the live distro appears a list of
  "Buffer I/O error on device sr0"  and than the monitor go in a power-saving
state and the system remain freezed.

As I'm using a live-cd I don't think I can recover the Xorg.0.conf

I download and try to install the dvd version and let you have news...
because unless there're options to boot not graphically the
Fedora-9-Preview-i686-Live.iso
I'm not able to boot it.

I'm testing also other distros .. I've noticed something interesting: al
distros based on xorg-server 1.3.0 and with ati drivers version 6.6.3   my
card worked perfectly (Fedora8, Slackware12, Debian 4.0_rc3, Ubuntu 7.10
...)  and at 1600x1200 resolution.
Instead there are problems with the new xorg-server and/or
xf86-video-ati-6.8.0 driver
For example yesterday a friend passed me a dvd containing the updated
slackware-current and at the evening, while awaiting for possible answers,
I've installed it. It uses xorg-server 1.4.0.90  and  ati-6.8.0   at the
startx it freezed.  I've recompiled the old ati-6.6.3  but obtained the same
result .. freezed. At the moment I've just the Xorg.0.log  of that
slackware-current .. I saved them.  I don't know if in the meantime I
download the fedora9 dvd they can be helpful for you.
In department I've another pc with my same ati card and downloaded other
recent distros, all using recent xorg and ati .. all freezed.
is it possible that it can be a xorg-server problem??

I'm at your complete disposal, let me know if I can post the slack
Xorg.0.log .. otherwise I'm downloading the fedora dvd .. I'll need 6 hour
to finish downloading it.

PS:  I send you that files ...   xorg.conf, Xorg.0.log  (they are slackware
ones, but they are the ones I've in the immediate)  .. when I'll have the
new ones I'll post you that ones too using the bugzilla.
Comment 3 Matěj Cepl 2008-04-21 18:21:38 EDT
Created attachment 303220 [details]
output of dmesg
Comment 4 Matěj Cepl 2008-04-21 18:22:03 EDT
Created attachment 303221 [details]
Xorg.0.log from Slackware
Comment 5 Matěj Cepl 2008-04-21 18:22:28 EDT
Created attachment 303222 [details]
xorg.conf from Slackware
Comment 6 Matěj Cepl 2008-04-21 18:23:43 EDT
Looking forward to see whether you managed to get some useful information from
the DVD.
Comment 7 Matěj Cepl 2008-04-21 18:34:42 EDT
Sorry, one more thing (rather important I am afraid) -- this cannot be only xorg
bug. /dev/sr0 is a device for the RW CD drive.

Reassigning to more appropriate component and keeping us on the CC list for
further debugging.
Comment 8 Nicola Ricciarelli 2008-04-22 08:36:14 EDT
Created attachment 303298 [details]
dmesg   - Fedora-9-Preview-i386-DVD
Comment 9 Nicola Ricciarelli 2008-04-22 08:37:00 EDT
Created attachment 303299 [details]
Xorg.0.log    -  Fedora-9-Preview-i386-DVD
Comment 10 Nicola Ricciarelli 2008-04-22 08:38:24 EDT
Created attachment 303300 [details]
xorg.conf  -   
Fedora-9-Preview-i386-DVD

I've changed nothing of the original xorg.conf
Comment 11 Nicola Ricciarelli 2008-04-22 08:43:01 EDT
for what concerns the  /dev/sr0  problem ... i don't know:  as you can see
looking at the dmesg it works perfectly and the cd-rw I used  is perfect:  new
and I've recorded there also other distro (archlinux,..) and they worked good,
no error messages.
Comment 12 Chuck Ebbert 2008-04-23 23:21:29 EDT
You can add " 3" to the boot arguments after pressing <tab> on the first screen
and the livecd will boot to runlevel 3 (text mode.)  The normal user name is
'fedora' with a blank password and root also has a blank password.
Comment 13 Matěj Cepl 2008-04-23 23:35:27 EDT
Reassigning back to Xorg component.
Comment 14 Bug Zapper 2008-05-14 05:43:36 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Bug Zapper 2009-06-09 20:17:00 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Bug Zapper 2009-07-14 13:28:41 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.