Bug 44323 - The rc start script is wrong
The rc start script is wrong
Status: CLOSED DUPLICATE of bug 37463
Product: Red Hat Linux
Classification: Retired
Component: ypbind (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-12 16:19 EDT by hjl
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-12 16:19:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
A patch (1.16 KB, patch)
2001-06-12 16:19 EDT, hjl
no flags Details | Diff

  None (edit)
Description hjl 2001-06-12 16:19:13 EDT
The curent one has:
 
       pid=`pidofproc ypbind`
        if [ -n "$pid" ]; then
          echo -n $"Listening for an NIS domain server."
          times=1
          until ypwhich > /dev/null 2>&1 || [ "$times" = "3" ]
          do
             RETVAL=$?
             echo -n "."
             times=$[$times+1]
          done
        fi

It has several problems:

1. If first time ypwhich failes, RETVAL will always be non-zero. 
2. There is no sleep in bewteen. On my network, it may take up to
15 seconds from starting ypbind to working ypwhich.
Comment 1 hjl 2001-06-12 16:19:52 EDT
Created attachment 20887 [details]
A patch
Comment 2 hjl 2001-06-19 16:57:38 EDT

*** This bug has been marked as a duplicate of 37463 ***

Note You need to log in before you can comment on or make changes to this bug.