Bug 443230 - knotify always crashes on logout
Summary: knotify always crashes on logout
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase-workspace
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-19 13:54 UTC by Mary Ellen Foster
Modified: 2009-06-07 23:20 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-06-07 23:20:29 UTC
Type: ---


Attachments (Terms of Use)
knotify crash log (6.44 KB, application/octet-stream)
2008-04-19 13:54 UTC, Mary Ellen Foster
no flags Details
Knotify crash log with better debuginfo (4.18 KB, application/octet-stream)
2008-04-22 17:20 UTC, Mary Ellen Foster
no flags Details
knotify crash dump from crash at kde4.04 logout (6.77 KB, text/plain)
2008-05-23 18:27 UTC, Mike C
no flags Details
knotify4.kcrash (7.74 KB, application/octet-stream)
2008-06-02 18:46 UTC, QVirus
no flags Details

Description Mary Ellen Foster 2008-04-19 13:54:30 UTC
Description of problem:
Whenever I log out of KDE, I get a window saying that knotify crashed. I finally
managed to get a backtrace; note that I may be missing some debuginfo packages
so this may not be useful.

Version-Release number of selected component (if applicable):
kdebase-4.0.3-7.fc9.i386

Comment 1 Mary Ellen Foster 2008-04-19 13:54:30 UTC
Created attachment 303002 [details]
knotify crash log

Comment 2 Kevin Kofler 2008-04-19 13:58:33 UTC
Looks like something is screwed up in either Phonon or xine-lib.
Installing kdebase-runtime-debuginfo and xine-lib-debuginfo should get you a 
better backtrace.

Comment 3 Mary Ellen Foster 2008-04-21 10:22:19 UTC
I can't get it to crash any more; if it does, I'll grab the log and post it here.

Comment 4 Lukáš Tinkl 2008-04-21 12:31:33 UTC
OK, for now no bug, reopen if the problem persists.

Comment 5 Mary Ellen Foster 2008-04-22 17:20:08 UTC
Created attachment 303344 [details]
Knotify crash log with better debuginfo

It just crashed again (on logout), and I now have the debuginfo packages, so
here's a better backtrace.

Comment 6 Bug Zapper 2008-05-14 09:44:02 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Rex Dieter 2008-05-23 14:55:58 UTC
I see this from time to time, maybe 1 in 10 logouts, certainly not *always*, 
but ymmv.

Comment 8 Mike C 2008-05-23 18:27:41 UTC
Created attachment 306535 [details]
knotify crash dump from crash at kde4.04 logout

Before kde4.04 the crash showed too briefly to get any output, but now the
crash window holds so that there is time to capture the dump.

Comment 9 mb 2008-05-25 18:54:34 UTC
Same issue here, running kdebase-4.0.4-2.fc9.i386.

Before 4.0.4 the crash dialog flashed by too quickly to read.  Now it will stay
until you close it.

Happens occasionally, not always.

Comment 10 QVirus 2008-06-02 18:46:10 UTC
Created attachment 307550 [details]
knotify4.kcrash

Comment 11 Steven M. Parrish 2008-06-23 20:35:29 UTC
Have you found this problem in KDE 4.0.5?

Comment 12 Anne 2008-06-27 10:38:10 UTC
I did not see it when I logged out a few minutes ago.

Comment 13 Rex Dieter 2008-09-06 18:18:40 UTC
2 things to try:
1.  see if it's still reproducible with kde-4.1.0 (currently in udpates-testing, but hopefully coming soonish to stable updates when these start flowing out of infrastructure again).
2.  report remaining issues upstream to bugs.kde.org

Comment 14 Steven M. Parrish 2009-02-06 17:14:53 UTC
Is this still an issue with 4.1.4?  If so please report upstream.

Comment 15 Anne 2009-02-09 15:45:25 UTC
I have not seen this problem since I reported Comment #12

Comment 16 Steven M. Parrish 2009-06-07 23:20:10 UTC
Based on previous comments going to close this as WORKSFORME.  Feel free to reopen if the problem returns.

-- 
Steven M. Parrish - KDE Triage Master
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.