Bug 443243 - Unable to Install Fedora 9 preview release, floating point error
Unable to Install Fedora 9 preview release, floating point error
Status: CLOSED DUPLICATE of bug 439160
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-04-19 13:29 EDT by adam williams
Modified: 2008-04-21 10:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-21 10:28:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
zip of the 3 photographs in my description field (100.18 KB, application/zip)
2008-04-19 13:29 EDT, adam williams
no flags Details
anaconda.log (7.83 KB, text/plain)
2008-04-20 17:07 EDT, adam williams
no flags Details
anacdump.txt created using updates=http://people.redhat.com/clumens/443243.img (90.32 KB, text/plain)
2008-04-21 09:09 EDT, adam williams
no flags Details

  None (edit)
Description adam williams 2008-04-19 13:29:50 EDT
Description of problem:

Version-Release number of selected component (if applicable):

Anaconda 11 that comes with Fedora 9 Previous Release

How reproducible:

Every Time I try to install

Steps to Reproduce:
1.  I am attempting to install Fedora 9 Preview Release onto a Toshiba Satellite
2655xdvd/6.0 notebook.  It is a celeron 366 w/ 192 megs of ram, 40G disk, and
DVD-rom drive.  I am using the Fedora 9 preview release bootable dvd image for
i386.  I boot off of the CD and select to install or upgrade an existing system.
 It then boots as normal, I select language and keyboard.  It starts anaconda,
and says "You do not have enough ram to start the graphical installer.  Starting
text mode Installation"  The system only has 2 megabytes of video ram but I can
run X in 1024x768x16bpp just fine.  Anyway, then I continue on and select to
upgrade the existing system which is Fedora 8.93 (/dev/sda3).  sda1 is /boot,
and /dev/sda2 is a 1 gigabyte swap partition.  
2.  Then the installer continues on to "Transferring image to hard drive" and
"checking dependencies in packages selected for installation" and then the error
message comes up on the screen "There was an error running your transaction for
the following reason: float division" see photo at
3. So I hit back and it says "starting an install process.  This may take
several minutes..." and then I get the error "Your file systems have already
been activated.  You cannot go back past this point.  Would you like to continue
with the installation?" see photo http://www.squeezer.net/fedora9/IMG_0416.JPG
so I hit Continue, and then the installer runs for another few seconds and I'm
back at "There was an error running your transaction for the following reason:
float division" see photo http://www.squeezer.net/fedora9/IMG_0417.JPG
Actual results:

There was an error running your transaction for the following reason: float division

Expected results:

Anaconda to install Fedora 9 Preview release as normal.  Fedora 8 installed fine
on this system, and I upgraded fine from Fedora 8 to Fedora 8.93 with yum -y
upgrade --enablerepo=development

Additional info:
Comment 1 adam williams 2008-04-19 13:29:51 EDT
Created attachment 303006 [details]
zip of the 3 photographs in my description field
Comment 2 Chris Lumens 2008-04-20 16:25:01 EDT
Please attach /tmp/anaconda.log to this bug report.
Comment 3 adam williams 2008-04-20 17:07:43 EDT
Created attachment 303073 [details]
Comment 4 Chris Lumens 2008-04-21 04:06:25 EDT
Could you add updates=http://people.redhat.com/clumens/443243.img to your boot
argument and try again?  Adding this will result in a traceback.  I could use
the exception dump from that traceback.  What's going on here is that our error
handling is just catching all exceptions instead of being more specific so I
can't tell exactly where the float division error is coming from.  Thanks.
Comment 5 adam williams 2008-04-21 09:09:21 EDT
Created attachment 303141 [details]
anacdump.txt created using updates=http://people.redhat.com/clumens/443243.img
Comment 6 Chris Lumens 2008-04-21 10:28:56 EDT

*** This bug has been marked as a duplicate of 439160 ***

Note You need to log in before you can comment on or make changes to this bug.