Bug 443246 - eggdrop hangs at "futex(0x97a567c, FUTEX_WAIT_PRIVATE, 1, NULL"
eggdrop hangs at "futex(0x97a567c, FUTEX_WAIT_PRIVATE, 1, NULL"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tcl (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-04-19 14:43 EDT by Robert Scheck
Modified: 2008-04-23 03:07 EDT (History)
0 users

See Also:
Fixed In Version: tcl-8_5_1-4.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 03:07:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2008-04-19 14:43:35 EDT
Description of problem:
eggdrop hangs at "futex(0x97a567c, FUTEX_WAIT_PRIVATE, 1, NULL":

19253 read(7, "telnet (entering a handle)\n     "..., 4096) = 1798
19253 read(7, "", 4096)                 = 0
19253 close(7)                          = 0
19253 munmap(0xb7f9c000, 4096)          = 0
19253 stat64("/usr/share/eggdrop/help/set/cmds1.help", {st_mode=S_IFREG|0644,
st_size=11411, ...}) = 0
19253 open("/usr/share/eggdrop/help/set/cmds1.help", O_RDONLY) = 7
19253 fstat64(7, {st_mode=S_IFREG|0644, st_size=11411, ...}) = 0
19253 mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0)
= 0xb7f9c000
19253 read(7, "%{help=set botnet-nick}%{+n}\n###"..., 4096) = 4096
19253 read(7, "you want telnet-flood to apply e"..., 4096) = 4096
19253 read(7, "  reaches the size of 550 kiloby"..., 4096) = 3219
19253 read(7, "", 4096)                 = 0
19253 close(7)                          = 0
19253 munmap(0xb7f9c000, 4096)          = 0
19253 stat64("/usr/share/eggdrop/help/msg/cmds2.help", 0xbf906a04) = -1 ENOENT
(No such file or directory)
19253 stat64("/usr/share/eggdrop/help/cmds2.help", {st_mode=S_IFREG|0644,
st_size=20081, ...}) = 0
19253 open("/usr/share/eggdrop/help/cmds2.help", O_RDONLY) = 7
19253 fstat64(7, {st_mode=S_IFREG|0644, st_size=20081, ...}) = 0
19253 mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0)
= 0xb7f9c000
19253 read(7, "%{help=fixcodes}%{-}\n###  %bfixc"..., 4096) = 4096
19253 read(7, "ith a hostmask\n   that ends with"..., 4096) = 4096
19253 read(7, "reload, save\n%{help=save}%{+m|m}"..., 4096) = 4096
19253 read(7, "@\" if they are an op. The user\'s"..., 4096) = 4096
19253 read(7, "omatically)\n      %bl%b - halfop"..., 4096) = 3697
19253 read(7, "", 4096)                 = 0
19253 close(7)                          = 0
19253 munmap(0xb7f9c000, 4096)          = 0
19253 stat64("/usr/share/eggdrop/help/set/cmds2.help", 0xbf906a04) = -1 ENOENT
(No such file or directory)
19253 stat64("/usr/share/eggdrop/help/msg/core.help", 0xbf906a04) = -1 ENOENT
(No such file or directory)
19253 stat64("/usr/share/eggdrop/help/core.help", {st_mode=S_IFREG|0644,
st_size=7630, ...}) = 0
19253 open("/usr/share/eggdrop/help/core.help", O_RDONLY) = 7
19253 fstat64(7, {st_mode=S_IFREG|0644, st_size=7630, ...}) = 0
19253 mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0)
= 0xb7f9c000
19253 read(7, "%{help=help}%{-}\nDCC commands fo"..., 4096) = 4096
19253 read(7, "s a language from the language l"..., 4096) = 3534
19253 read(7, "", 4096)                 = 0
19253 close(7)                          = 0
19253 munmap(0xb7f9c000, 4096)          = 0
19253 stat64("/usr/share/eggdrop/help/set/core.help", 0xbf906a04) = -1 ENOENT
(No such file or directory)
19253 time(NULL)                        = 1208630145
19253 stat64("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2295, ...}) = 0
19253 stat64("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2295, ...}) = 0
19253 stat64("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2295, ...}) = 0
19253 write(4, "\0", 1)                 = 1
19253 futex(0x97a567c, FUTEX_WAIT_PRIVATE, 1, NULL

Version-Release number of selected component (if applicable):
eggdrop-1.6.18-16

How reproducible:
Everytime when executing "eggdrop" and having a eggdrop.conf in the directory,
but never when using "eggdrop -n" and having a eggdrop.conf in the directory.

Actual results:
eggdrop hangs at "futex(0x97a567c, FUTEX_WAIT_PRIVATE, 1, NULL"

Expected results:
No hangs, but how to solve that? ;-)
Comment 1 Robert Scheck 2008-04-21 17:33:55 EDT
Bah! This is not an eggdrop problem but a fscking one by tcl 8.5, see:

http://coding.derkeiler.com/Archive/Tcl/comp.lang.tcl/2008-01/msg00017.html
http://sourceforge.net/tracker/index.php?func=detail&aid=1470152&group_id=10894&atid=110894

Marcela, can you please solve this problem ASAP as it breaks eggdrop for Fedora 9
and makes it mostly unusable there for nearly all normal users? Thank you.
Comment 2 Marcela Mašláňová 2008-04-22 09:11:29 EDT
I suppose it will be needed tcl without threads as was mentioned here
http://groups.google.com/group/comp.lang.tcl/msg/ce6a1324bada8db0

Comment 3 Robert Scheck 2008-04-22 17:14:02 EDT
Will we get this solved before F9 gold? BTW, using "%configure --disable-threads" 
rather "%configure --enable-threads" works for me and gets eggdrop up again...

Note You need to log in before you can comment on or make changes to this bug.