Bug 443253 - /sbin/service ignores LC_MESSAGES and LANGUAGE
/sbin/service ignores LC_MESSAGES and LANGUAGE
Status: CLOSED DUPLICATE of bug 422141
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-19 15:30 EDT by Jarkko
Modified: 2014-03-16 23:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 12:08:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jarkko 2008-04-19 15:30:04 EDT
# locale
LANG=fi_FI.UTF-8
LC_CTYPE="fi_FI.UTF-8"
LC_NUMERIC="fi_FI.UTF-8"
LC_TIME="fi_FI.UTF-8"
LC_COLLATE="fi_FI.UTF-8"
LC_MONETARY="fi_FI.UTF-8"
LC_MESSAGES="fi_FI.UTF-8"
LC_PAPER="fi_FI.UTF-8"
LC_NAME="fi_FI.UTF-8"
LC_ADDRESS="fi_FI.UTF-8"
LC_TELEPHONE="fi_FI.UTF-8"
LC_MEASUREMENT="fi_FI.UTF-8"
LC_IDENTIFICATION="fi_FI.UTF-8"
LC_ALL=

# echo $LANGUAGE
en_GB.UTF-8:en_US.UTF-8:en.UTF-8

# service sshd restart
Suljetaan sshd:                                            [  OK  ]
Käynnistetään sshd:                                        [  OK  ]

--> Should be (should honor LANGUAGE):

# service sshd restart
Stopping sshd:                                             [  OK  ]
Starting sshd:                                             [  OK  ]


# LC_MESSAGES=en_GB.UTF-8 service sshd restart
Suljetaan sshd:                                            [  OK  ]
Käynnistetään sshd:                                        [  OK  ]

--> Should be (should honor LC_MESSAGES):

# LC_MESSAGES=en_GB.UTF-8 service sshd restart
Stopping sshd:                                             [  OK  ]
Starting sshd:                                             [  OK  ]


The correct way is to first check LANGUAGE, then LC_MESSAGES, and last LANG. Now
it always only checks LANG. As you see:

# LANG=en_GB.UTF-8 service sshd restart
Stopping sshd:                                             [  OK  ]
Starting sshd:                                             [  OK  ]


Only /sbin/service is broken, as you see:

# /etc/init.d/sshd restart
Stopping sshd:                                             [  OK  ]
Starting sshd:                                             [  OK  ]


This bug happens at least in F8:

# rpm -q --whatprovides /sbin/service 
initscripts-8.60-1.x86_64
Comment 1 Bill Nottingham 2008-04-21 12:08:07 EDT

*** This bug has been marked as a duplicate of 422141 ***

Note You need to log in before you can comment on or make changes to this bug.