Bug 443254 - IP address of DNS server is not saved
IP address of DNS server is not saved
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-19 15:54 EDT by Michal Kučera
Modified: 2008-04-28 00:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 00:45:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
I copied this file after network configuration (46 bytes, text/plain)
2008-04-21 12:37 EDT, Michal Kučera
no flags Details

  None (edit)
Description Michal Kučera 2008-04-19 15:54:03 EDT
Description of problem:
It is in Fedora-9-PR-KDE-i686-20080416. When I create new configuration of
network, everything is saved except DNS IP addresses. When I run
system-config-network again IP addresses of DNS servers are blank. 



Version-Release number of selected component (if applicable):
Fedora-9-PR-KDE-i686-20080416

How reproducible:


Steps to Reproduce:
1. Set the eth0 IP addresses. Save configuration. 
2. Restart system-config-network
3. Check IP of DNS. IP addresses are blank
  
Actual results:


Expected results:


Additional info:
Comment 1 Harald Hoyer 2008-04-21 03:05:18 EDT
can you check /etc/resolv.conf immediately after saving?
Comment 2 Michal Kučera 2008-04-21 12:37:43 EDT
Created attachment 303166 [details]
I copied this file after network configuration
Comment 3 Michal Kučera 2008-04-21 12:39:03 EDT
here I attached the requested file. I copied it after configuration of network. 
Comment 4 Harald Hoyer 2008-04-21 12:59:11 EDT
# generated by NetworkManager, do not edit!
Comment 5 Dan Williams 2008-04-21 13:12:06 EDT
DNS cannot be saved in resolv.conf, because that file is volatile depending on
the specific network connections that are up at the time.  DNS needs to be
stored as DNS1, DNS2, DNS3 in the ifcfg file for the device being edited.

When we switched from reading s-c-n profiles to reading ifcfg files from
/etc/sysconfig/network-scripts, we also switched to reading DNS from the ifcfg
files rather than the profile's resolv.conf.

Can you try adding:

DNS1=<your first DNS server>
DNS2=<your second DNS server>

to your /etc/sysconfig/network-scripts/ifcfg-eth0 ?

Comment 6 Michal Kučera 2008-04-22 15:58:02 EDT
Yes, I tried it and it is ok. It works. But I think adding the DNS server should
be possible via Network manager too. And this doesn't work. In Fedora 8 it is
possible to add DNS server via Network manager. 
Comment 7 Dan Williams 2008-04-23 09:46:46 EDT
Yeah, this will be fixed in an F8 update quite soon when I rebuild the current
F9 version for F8.
Comment 8 Dan Williams 2008-04-28 00:45:26 EDT
FYI I've built the latest NM snapshot in Koji for F8 as well.

Note You need to log in before you can comment on or make changes to this bug.