Bug 443255 - Keyboard navigation in icon view could be easily improved
Keyboard navigation in icon view could be easily improved
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
i686 Linux
low Severity low
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-19 16:02 EDT by m.
Modified: 2015-03-03 17:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-05 12:39:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description m. 2008-04-19 16:02:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008041301 Fedora/3.0-0.54.beta5.fc9 Firefox/3.0b5

Description of problem:
When I use right arrow to iterate over all items in a folder, it stops at the edge of the window. It would be nice if it could move me to the next row.

The same goes with the left arrow at the left edge: it could move to the previous row.

Version-Release number of selected component (if applicable):
2.22

How reproducible:
Always


Steps to Reproduce:
1. Open a folder with a large amount of files in the icon view.
2. Try to iterate over it with the keyboard.
3. See how painly it is when you reach the edge.

Actual Results:


Expected Results:


Additional info:
Comment 1 m. 2008-04-20 08:08:08 EDT
The issue is visible especially in a maximized window on a wide screen.
Comment 2 Matthias Clasen 2008-05-05 12:38:36 EDT
A change like this is best proposed and discussed upstream:

nautilus-list@gnome.org or
bugzilla.gnome.org

Note You need to log in before you can comment on or make changes to this bug.