Bug 443263 - totem always uses xine backend!!!
totem always uses xine backend!!!
Status: CLOSED DUPLICATE of bug 442895
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-19 17:00 EDT by Hans de Goede
Modified: 2008-04-21 13:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 13:49:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2008-04-19 17:00:01 EDT
Description of problem:
Totem always uses the xine-backend, running "totem-backend -b gstreamer" as root
does not change this.

The only way I've found to run totem using the gstreamer backend is by invoking:
totem-backend -b gstreamer totem as normal user.

This can be a rather nasty F-9 surprise for people like me who have spend a lot
of time to create a good gstreamer setup / have written lots of gstreamer
patches to get good multimedia support!

I would _really_ like to see this fixed before F-9, let me know if there is
anything I can do to help achieve that.

To reproduce:
start totem, or a website with embedded media which will start the totem plugin.
Goto the about bix, it will always say: "using xine-lib version 1.1.11.1",
independent of how you've configured things through totem-backend.
Comment 1 Martin Jürgens 2008-04-19 17:11:38 EDT
I am running into the same issue and additionally think that this is a F9blocker. 

Actually, I did not even note that Totem switched to Xine, as I explicitly was
running Gstreamer some time earlier in the F9 cycle.
Comment 2 Bastien Nocera 2008-04-21 13:49:50 EDT
That's because the alternatives file gets removed in the postun on upgrade.

*** This bug has been marked as a duplicate of 442895 ***

Note You need to log in before you can comment on or make changes to this bug.