Bug 443277 - Yum crashes after downloading
Yum crashes after downloading
Status: CLOSED DUPLICATE of bug 444241
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-19 23:47 EDT by John Marick
Modified: 2014-01-21 18:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-07 17:26:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
produced error (1.30 KB, text/plain)
2008-04-19 23:47 EDT, John Marick
no flags Details

  None (edit)
Description John Marick 2008-04-19 23:47:08 EDT
Description of problem:Component: pirut
Summary: TB009f9c28 rpmsack.py:206:_all_packages:TypeError: rpmdb open failed

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 117, in _pageSwitch
    self.pageMap[num]()
  File "/usr/sbin/pirut", line 322, in _showBrowse
    grpsel.doRefresh()
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 512, in
doRefresh
    if len(self.ayum.comps.categories) == 0:
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 545, in <lambda>
    comps = property(fget=lambda self: self._getGroups(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 520, in _getGroups
    pkglist = self.rpmdb.simplePkgList()
  File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 158, in simplePkgList
    return self.pkglist
  File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 59, in _get_pkglist
    self._make_header_dict()
  File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 235, in
_make_header_dict
    for (hdr, idx) in self._all_packages():
  File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 206, in _all_packages
    mi = ts.dbMatch()
TypeError: rpmdb open failed

Local variables in innermost frame:
self: <yum.rpmsack.RPMDBPackageSack object at 0x2a96fd0>
ts: <rpmUtils.transaction.TransactionWrapper instance at 0xc652dd0>


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1.Run yum install on any program
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Marick 2008-04-19 23:47:08 EDT
Created attachment 303036 [details]
produced error
Comment 2 Seth Vidal 2008-04-21 12:08:08 EDT
Do you get this error every time?
Comment 3 James Antill 2008-08-07 17:26:32 EDT

*** This bug has been marked as a duplicate of bug 444241 ***

Note You need to log in before you can comment on or make changes to this bug.