Bug 443278 - RFE: error dialogs need to allow selectable text
RFE: error dialogs need to allow selectable text
Status: CLOSED DUPLICATE of bug 440279
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-20 00:03 EDT by Andrew Farris
Modified: 2008-04-21 13:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 13:17:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot-Update_System.png (67.70 KB, image/png)
2008-04-20 00:03 EDT, Andrew Farris
no flags Details

  None (edit)
Description Andrew Farris 2008-04-20 00:03:07 EDT
Description of problem:
Error dialogs for PackageKit should allow the user to drag/select the text for X
copy to report bugs.  Currently several dialogs do not allow any text to be
selected (in Gnome while using Metacity or Compiz at least).

Additional Info:

Leon Stringer reports to fedora-test-list (the dialog that is broken, Seth Vidal
already replied as to the fix for the update failure):

If I try to update my F9 install I now get "An internal system error has occurred".

I've attached a screenshot as I don't fancy typing in all the Python errors,
although here's the first few:

  Error Type: <type 'exceptions.UnboundLocalError'>
  Error Value: local variable 'r_e' referenced before assignment
    File: /usr/share/PackageKit/helpers/yum/update-system.py , line 18, in <module>
      backend.update_system()
  :
  :
  :

(As an aside, it would probably be better if users could select the text in this
error dialog).
Comment 1 Andrew Farris 2008-04-20 00:03:07 EDT
Created attachment 303037 [details]
Screenshot-Update_System.png
Comment 2 Andrew Farris 2008-04-20 00:03:52 EDT
Alternately, the dialog could include a first line indicating where the message
was saved to text output for the user to access.
Comment 3 Richard Hughes 2008-04-20 14:26:30 EDT
The internal error is a yum problem - just do "yum update yum" and then you can
use PackageKit as normal. In git master I've made the text selectable and
scrollable in a textbox, but it's not trivial to backport for F9. I can rewrite
the patch for F9 if you think this is important.
Comment 4 Andrew Farris 2008-04-20 16:22:49 EDT
I think it is important for F9 during its lifetime, but I wouldn't think its critical to get out the door at 
release.  This does make it much harder for people to report bugs, or in some dialogs to even see all that 
is going on (especially small screens).  The sooner the better for F9... but IMO not ahead of actually fixing 
anything else that is causing the errors.  If it can be backported in an early F9 update then I'd suggest 
that.
Comment 5 Richard Hughes 2008-04-21 13:17:36 EDT

*** This bug has been marked as a duplicate of 440279 ***

Note You need to log in before you can comment on or make changes to this bug.