Bug 443283 - httpd does nto start
httpd does nto start
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
rawhide
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-20 02:36 EDT by n_k_samal
Modified: 2008-04-21 15:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 15:42:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description n_k_samal 2008-04-20 02:36:50 EDT
Description of problem:
httpd does not start from system-config-services

Version-Release number of selected component (if applicable):
httpd as it comes with Fedora-9-Beta-i386

How reproducible:
start httpd service from system-config-services

Steps to Reproduce:
1.Go to Application
2.Go to Service
3.Go to httpd
4.Enable httpd
5.Start httpd
Actual results:
no response for very long time 

Expected results:
httpd service should have started and the disconnect icon (plug away from 
socket)should have changed to connect icon (plug in socket)

Additional info:
I tried enable/disable, and start/stop/restart MySQL, and the changes took 
place almost immediately.
With httpd enabling and disabling was instanteneous but none of the three 
options start/stop/restart worked.
While pressing restart button for httpd the status information in top right 
center of the window was refreshing httpd and not restarting httpd.
Enable/disable network was quick but start/stop/restart for network was taking 
about 60-90 seconds.
Comment 1 n_k_samal 2008-04-20 02:39:48 EDT
Full profile of the machine is at http://www/smolt.org/show?/uuid=pub_85955a62-
7804-46c3-9010-eb5cf098549a.
Comment 2 Flóki Pálsson 2008-04-20 15:36:28 EDT
httpd  works in httpd-2.2.8-3.x86_64  Fedora 9 Preview Release.
Comment 3 n_k_samal 2008-04-21 04:48:05 EDT
Today again I have tried few times but httpd does not start. 
Perhaps in Fedora-9-Beta-x86_64 the problem does not exist but there is some
glitch somewhere in Fedora-9-Beta-i386 running on i686 machines.
The system just gives a message "The status of this service is unknown".
Comment 4 Joe Orton 2008-04-21 04:48:49 EDT
What is the output from running "service httpd start" from a root shell?

What version of httpd? (rpm -q httpd)
Comment 5 n_k_samal 2008-04-21 10:10:30 EDT
I logged in as root and opened terminal and this is output is as follows.

[root@SrDME ~]# service httpd start
Starting httpd: httpd: apr_sockaddr_info_get() failed for SrDME
httpd: Could not reliably determine the server's fully qualified domain name,
using 127.0.0.1 for ServerName
                                                           [FAILED]

[root@SrDME ~]# rpm -q httpd
httpd-2.2.8-3.i386

SrDME is the name of the computer.
Comment 6 Joe Orton 2008-04-21 15:42:00 EDT
The machine's hostname should be fully-qualified, and needs to be resolvable
(e.g. via /etc/hosts); please ask on a user support forum if you need further help.

Note You need to log in before you can comment on or make changes to this bug.