This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 443300 - UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 46: ordinal not in range(128)
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-04-20 09:02 EDT by Nicolas Mailhot
Modified: 2013-01-09 20:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-05 13:55:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2008-04-20 09:02:31 EDT
Description of problem:

$ mock -r local
/var/lib/mock-builder/rpm/SRPMS/xkeyboard-config-1.3-0.120080420cvs.fc9.nim.src.rpm
INFO: mock.py version 0.9.8 starting...
State Changed: init plugins
State Changed: start
INFO:
Start(/var/lib/mock-builder/rpm/SRPMS/xkeyboard-config-1.3-0.120080420cvs.fc9.nim.src.rpm)
 Config(fedora-development-x86_64-local)
State Changed: lock buildroot
State Changed: clean
State Changed: init
State Changed: lock buildroot
INFO: enabled root cache
INFO: root cache aged out! cache will be rebuilt
INFO: enabled yum cache
State Changed: cleaning yum metadata
INFO: enabled ccache
State Changed: running yum
ERROR:
Exception(/var/lib/mock-builder/rpm/SRPMS/xkeyboard-config-1.3-0.120080420cvs.fc9.nim.src.rpm)
Config(fedora-development-x86_64-local) 2 minutes 31 seconds
INFO: Results and/or logs in: /var/lib/mock//fedora-development-x86_64-local/result
ERROR: Command failed: 
 # /usr/bin/yum --installroot
/var/lib/mock/fedora-development-x86_64-local/root/  groupinstall buildsys-build

=============================================================================
 Paquetage               Architecture  Version          Dépôt             Taille
=============================================================================
Installation:
 bash                    x86_64     3.2-22.fc9       fedora-devel      1.8 M
 bzip2                   x86_64     1.0.5-1.fc9      fedora-devel       50 k
 coreutils               x86_64     6.10-18.fc9      fedora-devel      4.5 M
 cpio                    x86_64     2.9-7.fc9        fedora-devel      185 k
 diffutils               x86_64     2.8.1-21.fc9     fedora-devel      215 k
 fedora-release          noarch     8.93-1           fedora-devel       28 k
 findutils               x86_64     1:4.2.33-3.fc9   fedora-devel      343 k
 gawk                    x86_64     3.1.5-17.fc9     fedora-devel      984 k
 gcc                     x86_64     4.3.0-7          fedora-devel       10 M
 gcc-c++                 x86_64     4.3.0-7          fedora-devel      4.3 M
 grep                    x86_64     2.5.1-59.fc9     fedora-devel      184 k
 gzip                    x86_64     1.3.12-6.fc9     fedora-devel      117 k
 info                    x86_64     4.11-5.fc9       fedora-devel      173 k
 make                    x86_64     1:3.81-12.fc9    fedora-devel      485 k
 patch                   x86_64     2.5.4-32.fc9     fedora-devel       64 k
 redhat-rpm-config       noarch     9.0.2-1.fc9      fedora-devel       54 k
 rpm-build               x86_64     4.4.2.3-2.fc9    fedora-devel      306 k
 sed                     x86_64     4.1.5-10.fc9     fedora-devel      189 k
 shadow-utils            x86_64     2:4.1.1-1.fc9    fedora-devel      1.2 M
 tar                     x86_64     2:1.19-3.fc9     fedora-devel      921 k
 unzip                   x86_64     5.52-9.fc9       fedora-devel      154 k
 util-linux-ng           x86_64     2.13.1-6.fc9     fedora-devel      2.0 M
 which                   x86_64     2.19-3.fc9       fedora-devel       39 k
Installation pour dépendance:
 ConsoleKit-libs         x86_64     0.2.10-3.fc9     fedora-devel       15 k
 audit-libs              x86_64     1.7.2-6.fc9      koji-f9-builds     74 k
 basesystem              noarch     8.1-1            fedora-devel      2.9 k
 binutils                x86_64     2.18.50.0.6-2    fedora-devel      3.1 M
 bzip2-libs              x86_64     1.0.5-1.fc9      fedora-devel       37 k
 chkconfig               x86_64     1.3.37-2         fedora-devel      157 k
 cpp                     x86_64     4.3.0-7          fedora-devel      3.4 M
 cracklib                x86_64     2.8.12-2         fedora-devel       48 k
 cracklib-dicts          x86_64     2.8.12-2         fedora-devel      3.7 M
 crontabs                noarch     1.10-19.fc9      fedora-devel      7.4 k
 db4                     x86_64     4.6.21-5.fc9     fedora-devel      590 k
 dbus                    x86_64     1.2.1-1.fc9      fedora-devel      249 k
 dbus-libs               x86_64     1.2.1-1.fc9      fedora-devel      128 k
 device-mapper-libs      x86_64     1.02.24-11.fc9   fedora-devel       64 k
 e2fsprogs-libs          x86_64     1.40.8-2.fc9     fedora-devel      133 k
 elfutils                x86_64     0.133-3.fc9      fedora-devel      214 k
 elfutils-libelf         x86_64     0.133-3.fc9      fedora-devel       53 k
 elfutils-libs           x86_64     0.133-3.fc9      fedora-devel      173 k
 expat                   x86_64     2.0.1-5          fedora-devel       83 k
 fedora-release-notes    noarch     8.92-1           fedora-devel      3.3 M
 file                    x86_64     4.23-5.fc9       fedora-devel       30 k
 file-libs               x86_64     4.23-5.fc9       fedora-devel      320 k
 filesystem              x86_64     2.4.13-1.fc9     fedora-devel      120 k
 gdbm                    x86_64     1.8.0-28.fc9     fedora-devel       28 k
 glibc                   x86_64     2.8-1            fedora-devel      4.9 M
 glibc-common            x86_64     2.8-1            fedora-devel       21 M
 glibc-devel             x86_64     2.8-1            fedora-devel      2.5 M
 glibc-headers           x86_64     2.8-1            fedora-devel      601 k
 gmp                     x86_64     4.2.2-7.fc9      fedora-devel      229 k
 kernel-headers          x86_64     2.6.25-1.fc9     fedora-devel      707 k
 less                    x86_64     418-3.fc9        fedora-devel      110 k
 libacl                  x86_64     2.2.47-1.fc9     fedora-devel       22 k
 libattr                 x86_64     2.4.41-1.fc9     fedora-devel       13 k
 libcap                  x86_64     2.06-4.fc9       fedora-devel       30 k
 libgcc                  x86_64     4.3.0-7          fedora-devel       61 k
 libgomp                 x86_64     4.3.0-7          fedora-devel       59 k
 libselinux              x86_64     2.0.61-1.fc9     fedora-devel      118 k
 libsepol                x86_64     2.0.26-1.fc9     fedora-devel      130 k
 libstdc++               x86_64     4.3.0-7          fedora-devel      311 k
 libstdc++-devel         x86_64     4.3.0-7          fedora-devel      3.8 M
 logrotate               x86_64     3.7.6-3.fc9      fedora-devel       52 k
 mpfr                    x86_64     2.3.0-3.fc9      fedora-devel      147 k
 ncurses                 x86_64     5.6-16.20080301.fc9  fedora-devel      169 k
 ncurses-base            x86_64     5.6-16.20080301.fc9  fedora-devel       59 k
 ncurses-libs            x86_64     5.6-16.20080301.fc9  fedora-devel      326 k
 nspr                    x86_64     4.7.0.99.2-2.fc9  fedora-devel      121 k
 nss                     x86_64     3.11.99.5-2.fc9  fedora-devel      1.2 M
 pam                     x86_64     1.0.0-2.fc9      fedora-devel      1.1 M
 pcre                    x86_64     7.3-3.fc9        fedora-devel      141 k
 perl                    x86_64     4:5.10.0-20.fc9  fedora-devel       14 M
 perl-Module-Pluggable   x86_64     1:3.60-20.fc9    fedora-devel       22 k
 perl-Pod-Escapes        x86_64     1:1.04-20.fc9    fedora-devel       16 k
 perl-Pod-Simple         x86_64     1:3.05-20.fc9    fedora-devel      181 k
 perl-libs               x86_64     4:5.10.0-20.fc9  fedora-devel      739 k
 perl-version            x86_64     3:0.74-20.fc9    fedora-devel       26 k
 popt                    x86_64     1.13-3.fc9       fedora-devel       39 k
 readline                x86_64     5.2-13.fc9       fedora-devel      190 k
 rpm                     x86_64     4.4.2.3-2.fc9    fedora-devel      1.2 M
 rpm-libs                x86_64     4.4.2.3-2.fc9    fedora-devel      948 k
 setup                   noarch     2.6.14-1.fc9     fedora-devel      140 k
 sqlite                  x86_64     3.5.6-2.fc9      fedora-devel      245 k
 tzdata                  noarch     2008b-1.fc9      fedora-devel      752 k
 zip                     x86_64     2.31-6.fc9       fedora-devel      127 k
 zlib                    x86_64     1.2.3-18.fc9     fedora-devel       75 k

Résumé de la transaction
=============================================================================
Installation     87 Paquetage(s)         
Mise à jour       0 Package(s)         
Suppression       0 Package(s)         

Taille totale des téléchargement : 101 M
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 241, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 193, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 354, in doTransaction
    problems = self.downloadPkgs(downloadpkgs) 
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 1096, in
downloadPkgs
    cache=po.repo.http_caching != 'none',
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 671, in getPackage
    cache=cache
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 649, in _getFile
    http_headers=headers,
  File "/usr/lib/python2.5/site-packages/urlgrabber/mirror.py", line 412, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.5/site-packages/urlgrabber/mirror.py", line 398, in
_mirror_try
    return func_ref( *(fullurl,), **kwargs )
  File "/usr/lib/python2.5/site-packages/urlgrabber/grabber.py", line 928, in
urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.5/site-packages/urlgrabber/grabber.py", line 863, in _retry
    cb_func(obj, *cb_args, **cb_kwargs)
  File "/usr/share/yum-cli/output.py", line 239, in failureReport
    self.logger.error('%s: %s', errobj.url, str(errobj.exception))
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 46:
ordinal not in range(128)

Version-Release number of selected component (if applicable):
yum-3.2.14-10.fc9.noarch
mock-0.9.8-1.fc9.noarch
Comment 1 Nicolas Mailhot 2008-04-20 09:03:12 EDT
$ locale
LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=
Comment 2 Nicolas Mailhot 2008-04-20 09:09:02 EDT
Retrying in another locale I get this error
http://redhat.download.fedoraproject.org/pub/fedora/linux/development/x86_64/os/Packages/device-mapper-libs-1.02.24-11.fc9.x86_64.rpm:
[Errno -1] Package does not match intended download

So probably rawhide packages are being signed, and the corresponding localized
message made yum/mock barf
Comment 3 Bug Zapper 2008-05-14 05:46:56 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Jesse Keating 2008-10-03 19:07:53 EDT
I don't suppose this is still a problem for you?  I think yum got a ton of unicode fixes over the past few months.
Comment 5 Nicolas Mailhot 2008-10-04 09:44:56 EDT
I haven't triggered this recently (but then I didn't have much time to do packaging and use mock either)
Comment 6 Diego 2010-08-18 03:21:02 EDT
I'm experiencing this problem. Could it be because of a broken package or is it caused by yum?

# yum check
Plugin abilitati:auto-update-debuginfo, presto, refresh-packagekit
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 258, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 113, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 396, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 1425, in doCommand
    header=lambda x: None):
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 1307, in _rpmdb_warn_checks
    out(prob)
  File "/usr/share/yum-cli/yumcommands.py", line 1421, in _out
    print x
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe8' in position 27: ordinal not in range(128)

# rpm -q yum
yum-3.2.28-3.fc13.noarch

Note You need to log in before you can comment on or make changes to this bug.