Bug 443304 - Unison fails with "Out of memory" error
Unison fails with "Out of memory" error
Status: CLOSED DUPLICATE of bug 441685
Product: Fedora
Classification: Fedora
Component: unison227 (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Stephen Warren
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-20 09:32 EDT by Manuel Morales
Modified: 2008-05-14 07:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-14 07:34:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manuel Morales 2008-04-20 09:32:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008041301 Fedora/3.0-0.54.beta5.fc9 Firefox/3.0b5

Description of problem:
When synchronizing directories with a large number of files, I get an out of memory error. Running with "-debug all" shows the following:

Growing heap to 10132k bytes
Growing page table to 34357992238 entries
No room for growing page table
Uncaught exception Out of memory

Version-Release number of selected component (if applicable):
unison227-2.27.57-8.fc9.x86_64

How reproducible:
Always


Steps to Reproduce:
1. Start unison
2. Synchronize directories
3. Out of memory and crash

Actual Results:


Expected Results:


Additional info:
Comment 1 John Poelstra 2008-04-21 13:28:24 EDT
thanks for reporting this bug
Comment 2 Dan Winship 2008-05-12 20:09:15 EDT
This only happens with the x86_64 package; if you install unison227.i386 instead
it works fine. So it's some sort of 64-bit uncleanliness.
Comment 3 Bug Zapper 2008-05-14 05:47:02 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Stephen Warren 2008-05-14 07:34:05 EDT

*** This bug has been marked as a duplicate of 441685 ***

Note You need to log in before you can comment on or make changes to this bug.