Bug 443309 - firefox looks ugly in kde 4 (gtk theme wrong)
firefox looks ugly in kde 4 (gtk theme wrong)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-20 10:35 EDT by Philipp N.
Modified: 2008-05-21 06:58 EDT (History)
7 users (show)

See Also:
Fixed In Version: 4.0.4-4.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 06:58:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
don't lost SystemGtkrc (1.03 KB, patch)
2008-05-08 11:03 EDT, Rex Dieter
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 146779 None None None Never

  None (edit)
Description Philipp N. 2008-04-20 10:35:04 EDT
Description of problem:
Firefox looks really ugly, because the gtk theme is wrong or something.

Version-Release number of selected component (if applicable):
fedora 9 kde4 live cd

How reproducible:
install firefox and just look

Steps to Reproduce:
1. boot live cd
2. yum install firefox
3. firefox
  
Actual results:
http://img512.imageshack.us/img512/1756/snapshot1se8.png

Expected results:
similar to gnome fedora 9 or something

Additional info:
probably it is the gtk theme?!
Comment 1 Christopher Aillon 2008-04-20 10:45:45 EDT
Firefox just reads the system settings, so this definitely isn't a firefox bug.
 I'm guessing the KDE4 spin needs to somehow set the default GTK theme or
something to match what is used in the default GNOME spin or something?

Sending over to KDE for now, but this is probably a spins issue...  not sure who
gets that.
Comment 2 Rex Dieter 2008-04-20 12:24:37 EDT
"Firefox just reads the system settings", what exactly does that mean?
Shouldn't the default gtk2 theme "just work"?

I'll have to double-check whether this applies to all gtk2-based (themed) apps
or just firefox.

Fwiw, I see proper theming on my box, but I've got both kde-desktop and
gnome-desktops installed.  Which implies to my untrained eye, that the gtk2
default theme isn't being pulled in or used automatically for some reason.
Comment 3 Christopher Aillon 2008-04-20 15:05:07 EDT
Right.  It needs to get pulled in.  If not, then there's not much firefox can
do.  It can't guess what the theme should be.
Comment 4 Kevin Kofler 2008-04-20 15:56:21 EDT
The Nodoka theme is on the KDE Live spin, the problem appears to be that it 
doesn't get enabled if nothing starts gnome-settings-daemon. The problem is: I 
don't understand why, because Nodoka is set as the systemwide default theme 
in /etc/gtk-2.0/gtkrc.
Comment 5 Rex Dieter 2008-05-06 13:54:29 EDT
pong over to kind gtk2 folks to help determine why nodoka isn't working in the
absence of g-s-d or possibly missing dep.
Comment 6 Matthias Clasen 2008-05-06 20:20:15 EDT
isn't this because kde is setting GTK2_RC_FILES to point to some gtkrc file of
its own ?
Comment 7 Kevin Kofler 2008-05-06 20:25:49 EDT
It sets it to a list of files, /etc/gtk-2.0/gtkrc is first in that list.
Comment 8 Rex Dieter 2008-05-07 10:02:21 EDT
Ugh, this may have something to do with it (from kde-settings):
/usr/share/kde-settings/kde-profile/default/share/config/gtkrc-2.0
don't remember when/how that got there.
Comment 9 Rex Dieter 2008-05-07 12:49:08 EDT
OK, that's not it, did
rm -f /usr/share/kde-settings/kde-profile/default/share/config/gtkrc-2.0
rm -f ~/.gtkrc*

logout/login, can now reproduce.

next stop, login to gnome, kill gnome-settings-daemon, see what happens.
Comment 10 Rex Dieter 2008-05-07 13:43:19 EDT
Tried testing under gnome too, but darn sucker (re)starts gnome-settings-daemon
every time I tried to kill it.

but... upon looking further, it *is* at least partly kde's fault:
$ set | grep gtk
GTK2_RC_FILES=/home/rdieter1/.gtkrc-2.0-kde4:/home/rdieter1/.kde/share/config/gtkrc-2.0
GTK_RC_FILES=:/home/rdieter1/.kde/share/config/gtkrc

No
/etc/gtk-2.0/gtkrc
in there.
Comment 11 Rex Dieter 2008-05-07 13:44:10 EDT
Oh, and appending /etc/gtk-2.0/gtkrc to GTK2_RC_FILES did the trick.
Comment 12 Kevin Kofler 2008-05-07 15:23:06 EDT
OK, then let's take the bug again. This is a KDE 4 regression, in KDE 3 the 
file is there. The code to add the file is still there in KDE 4 though, we'll 
have to look at what changed so we can revert it.
Comment 13 Kevin Kofler 2008-05-07 15:28:01 EDT
By "the file is there", I mean it's listed in GTK2_RC_FILES.
Comment 14 Rex Dieter 2008-05-08 08:50:21 EDT
related upstream report: http://bugs.kde.org/show_bug.cgi?id=146779
Comment 15 Kevin Kofler 2008-05-08 09:30:21 EDT
Looking into it, if I come up with a patch, I'll submit it to the upstream bug 
report too.
Comment 16 Kevin Kofler 2008-05-08 11:03:49 EDT
Should be fixed in kdebase-workspace-4.0.4-2.fc9 which is currently building. I 
wrote the patch, Rex tested and built it, that's teamwork. :-)

http://koji.fedoraproject.org/koji/buildinfo?buildID=48468
Comment 17 Rex Dieter 2008-05-08 11:03:57 EDT
Created attachment 304870 [details]
don't lost SystemGtkrc

Here's a patch we tested to work, to ensure that systemGtkrc doesn't get lost. 
Not sure exactly why the old code didn't work (it's almost the same as the kde3
versions that were ok).
Comment 18 Rex Dieter 2008-05-09 13:15:07 EDT
patch comitted upstream.
Comment 19 Fedora Update System 2008-05-13 11:22:59 EDT
kdebase-4.0.4-2.fc9, kdeaccessibility-4.0.4-1.fc9, kde-l10n-4.0.4-1.fc9, kdetoys-4.0.4-1.fc9, kdebindings-4.0.4-1.fc9, kdenetwork-4.0.4-2.fc9, kdegraphics-4.0.4-1.fc9, kdeartwork-4.0.4-1.fc9, kdesdk-4.0.4-1.fc9, kdegames-4.0.4-1.fc9, kdebase-workspace-4.0.4-4.fc9, kdeutils-4.0.4-1.fc9, kdeedu-4.0.4-2.fc9, kdebase-runtime-4.0.4-1.fc9, kdemultimedia-4.0.4-1.fc9, kdelibs-4.0.4-1.fc9, kdeadmin-4.0.4-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase kdeaccessibility kde-l10n kdetoys kdebindings kdenetwork kdegraphics kdeartwork kdesdk kdegames kdebase-workspace kdeutils kdeedu kdebase-runtime kdemultimedia kdelibs kdeadmin'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-3664
Comment 20 Bug Zapper 2008-05-14 05:47:22 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 21 Dean Mander 2008-05-16 16:04:10 EDT
Update to *-4.0.4 fixes the problem for me.


Comment 22 Fedora Update System 2008-05-21 06:58:04 EDT
kdebase-workspace-4.0.4-4.fc9, kdebase-4.0.4-2.fc9, kde-l10n-4.0.4-1.fc9, kdesdk-4.0.4-2.fc9, kdemultimedia-4.0.4-2.fc9, kdelibs-4.0.4-4.fc9, kdeedu-4.0.4-2.fc9, kdebase-runtime-4.0.4-1.fc9, kdepimlibs-4.0.4-1.fc9, kdenetwork-4.0.4-2.fc9, kdegraphics-4.0.4-1.fc9, kdeaccessibility-4.0.4-1.fc9, kdeartwork-4.0.4-1.fc9, kdeutils-4.0.4-1.fc9, kdebindings-4.0.4-1.fc9, kdetoys-4.0.4-1.fc9, kdegames-4.0.4-2.fc9, kdeadmin-4.0.4-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.