Bug 443324 - Xorg starts with a resolution not supported by the monitor.
Xorg starts with a resolution not supported by the monitor.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
9
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Dave Airlie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-20 14:09 EDT by Diego
Modified: 2008-07-15 13:05 EDT (History)
2 users (show)

See Also:
Fixed In Version: xorg-x11-drv-ati 6.8.0.18.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-15 13:05:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A camera shot that shows how badly my monitor work with unsupported resolutions. (70.47 KB, image/jpeg)
2008-04-20 14:09 EDT, Diego
no flags Details
Screen capture of the default settings. (602.39 KB, image/png)
2008-04-20 14:13 EDT, Diego
no flags Details
Xorg.0.log (325.95 KB, text/plain)
2008-04-20 14:16 EDT, Diego
no flags Details
Xorg.0.log from Ubuntu 8.04 / Xorg 7.3 (87.41 KB, text/plain)
2008-04-28 13:07 EDT, Diego
no flags Details
Xorg.0.log for ATI Radeon X800 and HP A4576A (117.11 KB, text/plain)
2008-04-30 09:58 EDT, Joachim Frieben
no flags Details
Working xorg.conf (731 bytes, text/plain)
2008-05-06 16:33 EDT, Diego
no flags Details
Xorg.0.log with the bug fixed. (69.38 KB, text/plain)
2008-07-06 04:45 EDT, Diego
no flags Details

  None (edit)
Description Diego 2008-04-20 14:09:21 EDT
Description of problem:
On my PC with ATI Radeon 9500 card and Philips 109P2 monitor Fedora 9 Preview
starts (even during the boot-up screen) with a really strange resolution
(1600x1024) not supported by the monitor. The list of the supported resolutions
are listed in the Xorg.0.log.

Version-Release number of selected component (if applicable):
X.Org X Server 1.4.99.901 (1.5.0 RC 1)

How reproducible:
Always

Steps to Reproduce:
1. Insert the CD and boot
  
Actual results:
Starts in 1600x1024 and the screen is really dark and distorted (this resolution
is not supported and it could even damage my monitor!).

Expected results:
Starts in a normal resolution (1280x1024) or, at least, start with a supported
resolution (the monitor can do up to 1920x1440.

Additional info:
Changing resolution both from system-config-display and from
gnome-display-properties to a supported resolution fixes the problem.
Comment 1 Diego 2008-04-20 14:09:21 EDT
Created attachment 303063 [details]
A camera shot that shows how badly my monitor work with unsupported resolutions.
Comment 2 Diego 2008-04-20 14:13:22 EDT
Created attachment 303064 [details]
Screen capture of the default settings.

Here you have the default settings chosen by Fedora 9 Preview. I haven't
changed anything before that screenshot.
Comment 3 Diego 2008-04-20 14:16:57 EDT
Created attachment 303065 [details]
Xorg.0.log

As you can see 1600x1024 isn't in the list of resolutions supported by the
monitor.
Comment 4 Diego 2008-04-20 14:23:11 EDT
In case you need it, here you are original specs of the monitor:
http://www.rim2000.com/prod_desc/philips/2002/109p20.pdf
Comment 5 Dave Airlie 2008-04-20 16:23:37 EDT
where are you seeing the 1600x1024?

from the log file we are setting at 1600x1200 mode on the monitor which it
recommends to us..


Comment 6 Diego 2008-04-21 05:16:54 EDT
1600x1200 would be ok, but the actual output isn't in 1600x1200 because I
sometimes use it in other distros but it doesn't causes that (worrying) distortions.

Line 660 and 661 of the Xorg.0.log:
"(II) RADEON(0): Output VGA-0 using initial mode 1600x1024
after xf86InitialConfiguration"

However both system-config-display and gnome-display-properties list a lot of
unsupported resolutions (for example also 1680x1050).
Comment 7 Diego 2008-04-28 13:02:14 EDT
I took some time to test to figure out where the problem is.
I tested the system with 2 different distros (Ubuntu 8.04 and Fedora 9 
Preview) and 2 different video cards (Radeon 9500 - radeon driver - and 
GeForce MX 400 - nv driver).

I tested Ubuntu just because it was the only distro with XOrg 7.3 I had with 
me.

Results:

Ubuntu 8.04 - radeon - 1280x1024 @ 85Hz (really good choice)
Fedora 9 preview - radeon - 1600x1024 @ 60Hz (really bad, totally broken)
Ubuntu 8.04 - nv - 1600x1200 @ 60Hz (not a wonderful choice, but however 
perfectly working)
Fedora 9 preview - nv - 1600x1200 @ 60Hz (same as before)

So my guess is that there is something wrong in the latest radeon driver.

I'm going to attach XOrg 7.3 log from Ubuntu 8.04 with radeon for comparison. 
In case you need it I can also do a test with Fedora 8.
Comment 8 Diego 2008-04-28 13:07:35 EDT
Created attachment 304009 [details]
Xorg.0.log from Ubuntu 8.04 / Xorg 7.3

Packages versions:
xorg (1:7.3+10ubuntu10)
xserver-xorg-video-ati (1:6.8.0-1)
Comment 9 Diego 2008-04-28 13:12:43 EDT
Uh... I just noticed both Ubuntu 8.04 and Fedora 9 Preview use ati-6.8.0.
Don't know what it could be then...
Comment 10 Joachim Frieben 2008-04-30 09:58:50 EDT
Created attachment 304229 [details]
Xorg.0.log for ATI Radeon X800 and HP A4576A

Same problem here: without a suitable xorg.conf file, X defaults to a
resolution
of 1920x1080 stretching beyond the borders of my CRT, a 21" HP A4576A connected

to an ATI Radeon X800 via the VGA connector. The system is a fully updated
"rawhide" one. Interestingly, '/usr/sbin/monitor-probe-using-X radeon' returns:


after xf86InitialConfiguration
EISA ID: HWP11e0
Screen size: 40.0 cm x 30.0 cm (19.69 inches, aspect ratio 4/3 = 1.33)
Gamma: 2.5
Analog signal
Max video bandwidth: 230 MHz

	HorizSync 30-107
	VertRefresh 48-160

	# Monitor preferred modeline (73.7 Hz vsync, 80.0 kHz hsync, ratio 5/4)

	ModeLine "1280x1024" 135 1280 1344 1536 1688 1024 1027 1030 1085 -hsync

	-vsync

which is not perfect either: for a 21" CRT with an aspect ration of 4/3, the
optimum resolution is 1400x1050, and this is what I usually add to my xorg.conf

which is the reason why I cannot live without it.

PS: Could anybody correct the spelling of 'seperate' in this infamous phrase
'We only handle seperate sync.' written to Xorg.0.log in the Xorg git tree?
Thanks!
Comment 11 Dave Airlie 2008-05-06 03:01:44 EDT
Diego can you remove the monitor section from your xorg.conf file? it seems to
be confusing things and limiting the modes. do that and post a new xorg log file
if it doesn't work.

Joachim, you have a monitor that is flexible with the truth, it doesn't claim a
preferred mode from the looks of it. It does detail 1280x1024 so this is the
only thing we can autoconfig on it I need to add a quirk in the server to choose
the first mode as preferred.
Comment 12 Joachim Frieben 2008-05-06 03:58:44 EDT
/usr/sbin/monitor-probe-using-X returns a preferred mode line with
"1280x1024" which is what already earlier Xorg releases fell back
to. If Xorg can be made to choose again that one, then this is ok
with me, as I complained about picking 1920x1080@60Hz [which is far
from anything reaonable] in the first place.
Comment 13 Diego 2008-05-06 16:31:45 EDT
> Diego can you remove the monitor section from your xorg.conf file?
> it seems to be confusing things and limiting the modes.

I'm really sorry but... well... it does not have a monitor section at all.

I attach you my (working) xorg.conf (I think system-config-display has created
it when I set a supported resolution from it).

I also tried updating the system as of today and removing the old xorg.conf and
the result is:
- no new xorg.conf is generated in /etc/X11/;
- it still starts in 1600x1024.
Comment 14 Diego 2008-05-06 16:33:14 EDT
Created attachment 304686 [details]
Working xorg.conf
Comment 15 Bug Zapper 2008-05-14 05:48:27 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Diego 2008-07-06 04:42:20 EDT
This seems to be fixed now. I have done all the updates as of today and manually
installed xorg-x11-drv-ati 6.8.0.18.fc9 from koji's rpm and the problem is gone.
Now it starts correctly in 1600x1200@85Hz.

However I don't know if it's gone because of the updates or because of the new
driver.
Comment 17 Diego 2008-07-06 04:45:14 EDT
Created attachment 311090 [details]
Xorg.0.log with the bug fixed.

In the line #670 you can see that now X selects a valid resolution for my
monitor:

(II) RADEON(0): Output VGA-0 using initial mode 1600x1200
Comment 18 Matěj Cepl 2008-07-15 13:05:55 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.