Bug 443335 - Updated system-config-network in order to install/solve wifi configuration (ipw3945)
Updated system-config-network in order to install/solve wifi configuration (i...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-20 16:51 EDT by oscar andré
Modified: 2009-01-09 02:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:47:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description oscar andré 2008-04-20 16:51:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12

Description of problem:
After updating system-config-network, I can't start the 
graphical tool anymore. I also tried to install system-config-network-1.5.5-1, but system report conflicts with the installed version (system-config-network-1.4.7-1). 

Version-Release number of selected component (if applicable):
fedora (kernel 2.6.24.3-12.fc8)

How reproducible:
Always


Steps to Reproduce:
1.Start system-config-network
2.
3.

Actual Results:
Can not execute system-config-network

Expected Results:
system-config-network should start as before

Additional info:
Output error message:

Component: system-config-network
Version: 1.4.7
Summary: TB1fe56f53 NCHostsList.py:66:load:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 166, in runit
    window = mainDialog()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 253, in __init__
    self.load()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 279, in load
    self.loadProfiles()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 296, in loadProfiles
    profilelist = getProfileList()
  File "/usr/share/system-config-network/netconfpkg/NCProfileList.py", line 652, in getProfileList
    __PFList.load()
  File "/usr/share/system-config-network/netconfpkg/NCProfileList.py", line 87, in load
    self.loadprof(pr, profdir)
  File "/usr/share/system-config-network/netconfpkg/NCProfileList.py", line 140, in loadprof
    prof.HostsList.load( filename = profdir + '/hosts')
  File "/usr/share/system-config-network/netconfpkg/NCHostsList.py", line 66, in load
    entry.Hostname = tmp[1]
IndexError: list index out of range

Local variables in innermost frame:
comment: 
tmp: ['166.82.1.82']
badlines: []
self: HostsList.1.IP=127.0.0.1
HostsList.1.Hostname=localhost.localdomain
HostsList.1.AliasList.1=localhost
HostsList.1.AliasList.2=frumentolap
HostsList.2.IP=::1
HostsList.2.Hostname=localhost.localdomain
HostsList.2.AliasList.1=localhost
HostsList.2.AliasList.2=frumentolap
HostsList.3.IP=166.82.1.166
HostsList.3.Hostname=mlopez
HostsList.4.IP=166.82.1.76
HostsList.4.Hostname=fisicasum
HostsList.5.IP=166.82.1.97
HostsList.5.Hostname=garfield
HostsList.6.IP=166.82.1.21
HostsList.6.Hostname=pop.cenpat.edu.ar

lines: ['# Do not remove the following line, or various programs\n', '# that require network functionality will fail.\n', '127.0.0.1\tlocalhost.localdomain\tlocalhost\tfrumentolap\n', '::1\tlocalhost.localdomain\tlocalhost\tfrumentolap\n', '166.82.1.166\tmlopez\t\n', '166.82.1.76\tfisicasum\t\n', '166.82.1.97\tgarfield\t\n', '166.82.1.21\tpop.cenpat.edu.ar\t\n', '166.82.1.82\t\t\n', '166.82.1.238\tazul\t\n', '166.82.1.72\tandres\tnegra\n', '166.82.171\toscar\t\n']
filename: //etc/sysconfig/networking/profiles//default/hosts
alias: frumentolap
num: 9
error: None
conffile: <closed file '//etc/sysconfig/networking/profiles//default/hosts', mode 'r' at 0x955f920>
entry: Host.IP=166.82.1.82

line: 166.82.1.82
Comment 1 Harald Hoyer 2008-04-21 03:14:03 EDT
you have a bad line in /etc/hosts... and yes, s-c-network should not traceback.

'166.82.1.82\t\t\n'
Comment 2 oscar andré 2008-04-21 13:28:50 EDT
thank you for the comment.
have been able to install system-config-network-1.5.5-1; system-config-network
executed reporting the same problem and was solved.
Comment 3 Bug Zapper 2008-11-26 05:31:51 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2009-01-09 02:47:05 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.