Bug 443341 - Global name RefreshYumCacheFailed is not defined
Global name RefreshYumCacheFailed is not defined
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9PKBlocker
  Show dependency treegraph
 
Reported: 2008-04-20 17:29 EDT by Lubomir Kundrak
Modified: 2008-04-26 04:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-26 04:57:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of the problem (106.17 KB, image/png)
2008-04-20 17:29 EDT, Lubomir Kundrak
no flags Details
test patch (1.05 KB, patch)
2008-04-20 19:59 EDT, Richard Hughes
no flags Details | Diff

  None (edit)
Description Lubomir Kundrak 2008-04-20 17:29:51 EDT
See the attached screenshot for screenshot of the error I have encountered (do
not me why didn't I copy and paste the text). The problem was triggered by
searching for "source code indexer" and terminating with "Cancel" after a while.
Happened with yesterday's rawhide.
Comment 1 Lubomir Kundrak 2008-04-20 17:29:51 EDT
Created attachment 303075 [details]
screenshot of the problem
Comment 2 Richard Hughes 2008-04-20 19:59:52 EDT
Created attachment 303080 [details]
test patch

Robi, you can reproduce doing:

sudo yum clean all
gpk-application
<search for power, package lists start downloading>
<click cancel>
Bam:

Error Type: <type 'exceptions.NameError'>
Error Value: global name 'RefreshYumCacheFailed' is not defined
  File : /usr/share/PackageKit/helpers/yum/search-name.py , line 21, in
<module>
    backend.search_name(options,searchterms)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 422, in
search_name
    except RefreshYumCacheFailed, e:

Patch attached fixes the problem. Okay to apply?
Comment 3 Richard Hughes 2008-04-21 10:52:58 EDT
Robin has applied the patch to master. I'll pull to stable in a few minutes, and
build a F9 snapshot tmw.

Note You need to log in before you can comment on or make changes to this bug.