Bug 443343 - KDE3 programs aren't inheriting KDE4 colors
Summary: KDE3 programs aren't inheriting KDE4 colors
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-20 21:53 UTC by Kelly Miller
Modified: 2008-04-21 00:26 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 00:17:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 161098 None None None Never

Description Kelly Miller 2008-04-20 21:53:17 UTC
I've noticed while running KDE4 that KDE3 programs don't seem to inherit colors
properly (even if "apply to non-KDE4 programs" is clicked), so I'm going to drop
a hint from looking into the config files:

KDE4 stores colors under custom headers in the kdeglobals file.  KDE3 also
stored colors in kdeglobals, but under the [General] header. KDE4's color
adjuster does not write colors in [General] - I suspect that is why KDE3
programs don't inherit colors properly.

In short, the KDE4 color editor should be patched to write certain colors to the
[General] section of kdeglobals along with how it currently writes colors to
kdeglobals.  I've already tested this by editing the file manually, and
confirmed that there is no conflict. I'll give writing a patch myself a shot,
but I'm not entirely familiar with the inner workings of kdebase.

This is a Fedora bug, not a KDE bug, because this results from the specific way
Fedora is packaging KDE4 (both using the same user directory).

Comment 1 Kevin Kofler 2008-04-20 21:57:14 UTC
KDE 4 simply uses different color settings than KDE 3.

If you want to set your KDE 3 colors, install kdebase3 and run:
kcmshell colors

> This is a Fedora bug, not a KDE bug, because this results from the specific
> way Fedora is packaging KDE4 (both using the same user directory).

If we were using different configuration directories, then _nothing_ would get 
inherited, so it would only make things worse.

Comment 2 Kevin Kofler 2008-04-20 22:15:10 UTC
To sum up, I consider this a shortcoming in upstream KDE, I'm not sure I'd go 
as far as calling it a bug though.

Comment 3 Steven M. Parrish 2008-04-20 22:41:02 UTC
Did a search of bugs.kde.org and could find no bug/feature requests matching
this report.  Please submit upstream and add submission info to this report.

Comment 4 Kelly Miller 2008-04-21 00:04:47 UTC
Okay, I did so.  The upstream bug report is here:
http://bugs.kde.org/show_bug.cgi?id=161098

Comment 5 Kevin Kofler 2008-04-21 00:26:25 UTC
Thanks, we will continue to track this upstream. (I've added myself and the 3 
other KDE maintainers to the CC list for the upstream bug report.)


Note You need to log in before you can comment on or make changes to this bug.