Bug 443356 - [ja] rendering of Japanese is uglier than under Gtk/GNOME
[ja] rendering of Japanese is uglier than under Gtk/GNOME
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 00:02 EDT by Jens Petersen
Modified: 2008-04-30 12:11 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.4.0-12.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-30 12:11:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ja-Screenshot.png (101.86 KB, image/png)
2008-04-21 00:06 EDT, Jens Petersen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 64508 None None None Never

  None (edit)
Description Jens Petersen 2008-04-21 00:02:00 EDT
Description of problem:
The rendering of Japanese glyphs looks quite different from gtk/GNOME applications
(maybe similar to qt/KDE?).  To me the rendering under gtk is nicer.  Just
wondering what the story behind that is and if something can't be done to improve
the rendering in OpenOffice.

AFAIK this is not a new issue and could well affect other Asian languages too.
Comment 1 Jens Petersen 2008-04-21 00:06:18 EDT
Created attachment 303095 [details]
ja-Screenshot.png

Comparison of Openoffice.org and gedit using the text of the oowriter menubar.
Comment 2 Caolan McNamara 2008-04-21 03:45:28 EDT
To my untutored eyes it looks the same. except maybe for the 4th glyph, is that
the problem ?

In theory now we should be rendering the glyphs with cairo and using the same
fontconfig settings throughout OOo and gtk so if there's something different
then my first impression is that there is some little bug with some setting not
getting treated the same in both
Comment 3 Jens Petersen 2008-04-21 03:58:37 EDT
Are you comparing the gedit menubar say with the openoffice text?

(In reply to comment #2)
> To my untutored eyes it looks the same. except maybe for the 4th glyph, is that
> the problem ?

No every glyph is being rendered differently: naively it looks like there is
no anti-aliasing in the OpenOffice rendering.
Comment 4 Caolan McNamara 2008-04-21 07:06:14 EDT
grr....

[caolan@vain F-9]$ diff -u <( fc-match -v "VL Gothic" ) <( fc-match -v "VL ゴ
シック" )
--- /proc/self/fd/63    2008-04-21 12:05:28.873431540 +0100
+++ /proc/self/fd/62    2008-04-21 12:05:28.874431737 +0100
@@ -1,5 +1,5 @@
 Pattern has 30 elts (size 32)
-       family: "VL Gothic"(s)
+       family: "VL ゴシック"(s)
        familylang: "en"(s)
        style: "regular"(s)
        stylelang: "en"(s)
@@ -12,7 +12,7 @@
        pixelsize: 12.5(f)(s)
        foundry: "unknown"(s)
        hintstyle: 3(i)(s)
-       hinting: FcFalse(w)
+       hinting: FcTrue(s)
        verticallayout: FcFalse(s)
        autohint: FcFalse(s)
        globaladvance: FcTrue(s)


i.e. the "hinting is off in fontconfig" is not getting to Ooo if it uses the
localized font name, what a pain in my ass
Comment 5 Caolan McNamara 2008-04-21 08:21:30 EDT
*mumble* hatred, but should be doable by using the canonical name for fetching
the hints
Comment 6 Jens Petersen 2008-04-22 22:49:24 EDT
Thanks. :)

Is it built already in koji?
Comment 7 Caolan McNamara 2008-04-23 03:23:53 EDT
No, not yet. Will be in anything >= openoffice_org-2.4.0-12.7.fc9
Comment 8 Caolan McNamara 2008-04-24 03:59:55 EDT
Can you check 
http://koji.fedoraproject.org/packages/openoffice.org/2.4.0/12.7.fc9
for me ?
Comment 9 Jens Petersen 2008-04-28 04:00:55 EDT
Thank you that is a great improvement!

Note You need to log in before you can comment on or make changes to this bug.