Bug 443369 - Pungi fails when only a method/url command is given in the kickstart
Pungi fails when only a method/url command is given in the kickstart
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 04:09 EDT by Mark McLoughlin
Modified: 2013-01-09 23:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 08:55:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2008-04-21 04:09:47 EDT
If you just have:

  url --url http://foo

then pungi fails with:

  yum.Errors.GroupsError: No Groups Available in any repository

without the usual:

  Pungi.Gather:INFO: Adding repo ks-method-url

Basically, the problem is that repo.methodToRepo() fails unless there is a
"repo" command in the kickstart as well as the "method" command.

Patch here:

  https://www.redhat.com/archives/kickstart-list/2008-April/msg00046.html
Comment 1 Chris Lumens 2008-04-21 08:55:01 EDT
This will be fixed in the next build of pykickstart.  Thanks for the patch.

Note You need to log in before you can comment on or make changes to this bug.