Bug 44337 - mc dumbly allows one to edit a file inside an RPM
mc dumbly allows one to edit a file inside an RPM
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mc (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-12 18:59 EDT by Mike A. Harris
Modified: 2013-04-02 00:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-18 10:34:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2001-06-12 18:59:38 EDT
Description of Problem:  If you go inside an src.rpm archive in Midnight
Commander, it can be very easy to get your dirs mixed up for example
and hit "F4" to edit a file when comparing the inside of one src.rpm
against the a dir full of working files installed from an src.rpm.
mc lets you edit this file inside the rpm, and then you hit save and
it lets you save the file also.  Unfortunately you realize too late
that you are a total moron for trying to edit a file inside a src.rpm
instead of the other dir panel and so you lose 2 hours work because
mc gleefully lets you go ahead and do so, and even lets you believe
it saved the file.

How Reproducible: 100%


Steps to Reproduce:
1. First, you need to be a total moron
2. Second, stay up for 36 hours straight programming, etc.
3. Compare a directory of files you are working on (patches, spec files)
   with the inside of a previous src.rpm that you packaged after entering
   the src.rpm in a mc panel.
4. Inside the src.rpm, go to the specfile and hit F4, edit it for 2 hours
   and then hit save.  The screen you're on gives no indication you are
   inside a src.rpm, so you could easily have forgotten after switching
   between vc's, etc.  That is until youve EXITED, and then perhaps
   realized what a moron you are and that you just lost a bunch of work.

Actual Results:  mc lets you edit the file even though that is pointless

Expected Results:
1) mc should bring up a dialog saying "Operation not permitted" instead
   of making you believe it is ok.
2) Me not being a moron

Additional Information:
I'm going to go to sleep now.  Try not to laugh too hard at my
bad luck today.  ;o)
Comment 1 Jonathan Blandford 2001-07-16 16:29:43 EDT
This is not a priority for us to fix, but the mc maintainer has been notified of it.


Note You need to log in before you can comment on or make changes to this bug.