Bug 443372 - installation is asking about GPT partition table even with kickstart
Summary: installation is asking about GPT partition table even with kickstart
Status: CLOSED DUPLICATE of bug 188579
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 4.7
Hardware: ia64 Linux
low
low
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-21 08:35 UTC by Alexander Todorov
Modified: 2008-04-21 13:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 12:06:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexander Todorov 2008-04-21 08:35:51 UTC
Description of problem:
On uninitialized disk the installer is asking the user if the disk has a GPT
partition table or not. The kickstart has:

bootloader
#zerombr is off
clearpart --initlabel --all
autopart

%pre 
exec &>/tmp/kate-sda.out
test -b /dev/sda || mknod /dev/sda
if ! test -b /dev/sda; then
    echo Unable to find/create device for sda
    touch /tmp/fail
fi
if ! dd if=/dev/zero of=/dev/sda bs=512 count=1; then
    echo Unable to clear beginning of sda
    touch /tmp/fail
fi


Version-Release number of selected component (if applicable):
anaconda-10.1.1.86-1

How reproducible:
Not sure. Seen for the first time.

Steps to Reproduce:
1. install with the ks.cfg snippet above
  
Actual results:
Installer is asking the user to provide information

Expected results:
The installer should not ask the user for that info. ks.cfg has
"clearpart --initlabel --all" and it should initialize all disks.


Additional info:

Comment 1 Alexander Todorov 2008-04-21 08:36:39 UTC
The message is:

             |                                                   | 
             | /dev/sda contains GPT signatures, indicating      | 
             | that it has a GPT table.  However, it does not    | 
             | have a valid fake msdos partition table, as it    | 
             | should.  Perhaps it was corrupted - possibly by   | 
             | a program that doesn't understand GPT partition   | 
             | tables.  Or perhaps you deleted the GPT table,    | 
             | and are now using an msdos partition table.  Is   | 
             | this a GPT partition table?                       | 
             |                                                   | 
             |         +-----+                  +----+           | 
             |         | Yes |                  | No |           | 
             |         +-----+                  +----+           | 

Comment 3 Joel Andres Granados 2008-04-21 09:21:49 UTC
This is a parted message.  It pretty much describes what is happening.  Anaconda
ignoring this messages would be the right thing to do when "clearpart
--initlabel --all" is passed,  looking into this.

Comment 4 Joel Andres Granados 2008-04-21 09:41:08 UTC
(In reply to comment #2)
> KATE result (with complete ks.cfg)
> 
>
http://hank.test.redhat.com/kate/auto.cgi?action=case&group=RHEL4-U7-re20080418.0-ia64&case=uninitialized_disks-AS-releng-french-nfsiso-VNC

This is related to 220161.
The fixed has already been commited.
commit f7c12c05bf23d7d0a38cde184a633e978fcd1824
Guess it will appear in 10.1.1.87


Comment 6 Joel Andres Granados 2008-04-21 12:06:18 UTC

*** This bug has been marked as a duplicate of 188579 ***

Comment 7 Chris Lumens 2008-04-21 13:13:58 UTC
We need to see log files from this once the traceback has been fixed.


Note You need to log in before you can comment on or make changes to this bug.