Bug 443387 - Legacy menu items are all over the place...
Legacy menu items are all over the place...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: redhat-menus (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 05:55 EDT by Toralf
Modified: 2015-05-11 08:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 08:37:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The way I updated to xdg config files to get a cleaner menu (5.67 KB, patch)
2008-04-21 05:55 EDT, Toralf
no flags Details | Diff

  None (edit)
Description Toralf 2008-04-21 05:55:15 EDT
Description of problem:
I just upgraded to RHEL 5 on a system that has been around for a while, and
found that the desktop menus were so messy that they were hardly usable because
entries for various old software packages would appear all over the place.

The main problem is that *all* menu config files contain
<LegacyDir>/usr/share/gnome/apps/Settings</LegacyDir>
<LegacyDir>/etc/X11/applnk/Settings</LegacyDir>

At first glance, this seems to make sense, since it (you may think) it will make
sure entries on old-style locations are considered for rules appearing later
that include items acoording to keys or filenames. The problem is that LegacyDir
doesn't just mean "caching" the items that way; according to the freedesktop
menu spec, reading a legacy directory should also mean adding separate submenus
for all the subdirectories of the "legacy directory" - and that's also the way
it works in the current gnome-panel release. This effectively means bypassing
match rules in the config files most of the time, since they generally don't
apply to sub menus.

Another minor issue is that the names of some "standard" menus have changed over
the years, so it seems like a good idea to explitly "move" some old names to the
new ones.


Version-Release number of selected component (if applicable):
redhat-menus-6.7.8-2.el5

How reproducible:
Every time

Steps to Reproduce:
1. Store a file /etc/X11/applnk/Graphics/gv.desktop with the following contents

[Desktop Entry]
Name=Ghostview
Type=Application
Icon=kghostview.xpm
Exec=gv

2. Restart the gnome panel if necessary
3. Browse the menu
  
Actual results:
An entry "Ghostview" (correctly) appears under "Graphics" in the Applications
menu. It also appears in (new) menus System->Preferences->Graphics,
System->Administration->Graphics, System Preferences->More Preferences->Graphics
etc.


Expected results:
An entry "Ghostview" appears under "Graphics" in the Applications menu, and
nowhere else

Additional info:
I think I had the same problem after installation of RHEL4, too, but I just
edited the config files without telling anybody...
Comment 1 Toralf 2008-04-21 05:55:15 EDT
Created attachment 303127 [details]
The way I updated to xdg config files to get a cleaner menu
Comment 2 Toralf 2008-04-21 05:57:59 EDT
(In reply to comment #0)
Whoops. I actually copied data from my corrected rather than the original setup
config here:
> The main problem is that *all* menu config files contain
> <LegacyDir>/usr/share/gnome/apps/Settings</LegacyDir>
> <LegacyDir>/etc/X11/applnk/Settings</LegacyDir>

What the fils have is actually 

<LegacyDir>/usr/share/gnome/apps</LegacyDir>
<LegacyDir>/etc/X11/applnk</LegacyDir>

where it would probably more correct to include specific sub directories only
like in the above example.
Comment 3 RHEL Product and Program Management 2014-03-07 08:38:01 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 4 RHEL Product and Program Management 2014-06-03 08:37:00 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).
Comment 5 Toralf 2015-05-11 08:25:28 EDT
I keep getting emails saying that someone is waiting for my response to this issue, but I'm unsure why based on the request's status.

Note You need to log in before you can comment on or make changes to this bug.