Bug 443399 - flex bundle a static library only - what about a shared one ?
flex bundle a static library only - what about a shared one ?
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: flex (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Petr Machata
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 07:11 EDT by Nicolas Chauvet (kwizart)
Modified: 2015-05-04 21:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 12:26:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Chauvet (kwizart) 2008-04-21 07:11:37 EDT
Description of problem:
The flex version 2.5.35 currenly available in rawhide bundles only a static
library. Can we provide a shared one (and split the static one into a -static
sub-package if needed )?

Version-Release number of selected component (if applicable): F-9 could be fixed
to be tagged as f9-final. (at least it would be desirable). I don't know if it
matter to rebuild all dependent packages at this time for F-9



Additional info: I'm trying to package brlcad which links to -lfl . A shared
version should be detected by the configure script but it use the static one for
now.
Comment 1 Petr Machata 2008-04-21 08:09:27 EDT
We could, but there is little point.  First, flex would then have to provide
libflex in a separate package, because flex clients would be runtime dependent
on the shared library, which would somewhat complicate packaging both flex and
clients.  Second, and more important, the library provides only two symbols:
main and yywrap.  Both of them are trivial, with pretty much fixed
implementations.  I don't think usual arguments for shared libraries apply in
this case.

Note You need to log in before you can comment on or make changes to this bug.